No more Facebook for iOS 6?

Discussion in 'iOS 6' started by cryptonit, Jul 5, 2014.

  1. cryptonit macrumors newbie

    Joined:
    May 14, 2011
    #1
    I have iPhone 4 with iOS 6. I don't want to go to iOS 7. I can't find Facebook app for iOS 6 in App Store. There is only version requiring iOS 7. So, no more Facebook for old iOS?
     
  2. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #2
    Settings.app / general / software update.

    You can upgrade to 7 and fix all the wide open vulnerabilities of 6. AND get the Facebook app.
     
  3. sonicrobby macrumors 68020

    sonicrobby

    Joined:
    Apr 24, 2013
    Location:
    New Orleans
    #3
    He said he didn't want iOS7.

    You can't download the newest version from the app store, Im not sure if it works, but you can probably find an old version of the .ipa on the internet somewhere. Im not sure if they are linked to iCloud accounts for free apps, but I could send you mine. Im still on iOS6 on my iPhone 5
     
  4. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #4
    Will never understand some people's masochistic desire to have their stuff hacked.

    Different strokes *shrug*
     
  5. E2EK1EL macrumors 6502

    Joined:
    Nov 19, 2012
    #5
    Facebook Mobile App ver 11.0 is the last ver that will work with iOS 6

    The new update, ver 12.0 released on July 3 2014 is indeed iOS 7 only.


    Facebook should be smart enough to allow the legacy download if they weren't so dumb and want to make more cash.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    All iOS apps are tied to the original purchaser, whether free or not.

    ----------

    I'm sure Facebook isn't too terribly concerned about the small minority of iOS users who have devices compatible with 7 but won't upgrade.
     
  7. sonicrobby macrumors 68020

    sonicrobby

    Joined:
    Apr 24, 2013
    Location:
    New Orleans
    #7
    Actually, you should still be able to download it from the App store. You will get a pop-up saying something about blah blah iOS7, but at the bottom they give you the option to download the compatible app. So when the pop-up comes up, click "download"
     
  8. mhdena macrumors 6502

    Joined:
    Sep 16, 2009
    #8
    Still works on 6 for me.

    How is anyone just now getting 6 and not already have facebook?
     
  9. iamMacPerson macrumors 68030

    iamMacPerson

    Joined:
    Jun 12, 2011
    Location:
    AZ/10.0.1.1
    #9
    If you have downloaded it in the past, just try redownloading and it will ask if you want the compatible version. If you haven't downloaded it before, download it with your Apple ID onto a Mac or Windows PC through iTunes then redownload it to the phone from the App Store. Should ask you if you want a compatible version.
     
  10. teyteybuchiii macrumors newbie

    Joined:
    Aug 7, 2014
    #10
    i can't dwnload facebook from the app store :( im still on ios6
     
  11. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #11
    Please do some research before posting stuff like this. Actually apps use a filesystem called .IPA and they can be used by anyone, its just piracy to download payed ones.

    ----------

    The probability of that happinhing is so slim that its not really an issue... Like seriously, unless you are on public wifi constantly, or dont use any password protection, theres no point in updating...
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    No point of updating until you get bit by one of those pesky issues. Sure many won't, but try telling that to someone who will.
     
  13. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #13


    What I wrote is correct. Apps are connected to the Apple ID which originally "purchased" them. There's no way to remove the original purchaser from the app bundle and have it keep working, so if someone uses an app from someone else's Apple ID, that new user will always be prompted for the original user's Apple ID credentials if the new user tries to update it.
    Apps don't use filesystems. If you're going to be pedantic, get your own facts correct. http://en.wikipedia.org/wiki/File_system
     
  14. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #14
    Actually no. They use the apple id to update, but never to install. You can use ifunbox to i stall an ipa and it will work fine. Especially if its free. I have done this several times with my friends and i trading ipas....
     
  15. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #15
    I didn't mention installing.
     
  16. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #16
    well thats what the op is trying to do since he doesn't have it installed yet.... wow...
     
  17. digidude512 macrumors newbie

    Joined:
    Aug 17, 2014
    #17
    Tested Install

    This Method Doesn't Need iFunbox or Jailbreak.

    Go to Settings and open the Facebook Preference, Hit Install it'll ask for your iTunes Password hit Download when it asks you to Install an older version and then it will install with no issues.

    Just tested this 20 minutes ago on my iPod Touch 4 running iOS 6.1.6, Hope this helps anyone who needs it.
     
  18. jhay0712 macrumors newbie

    Joined:
    Sep 2, 2014
    #18
    facebook for ios 6

    how about my ipod touch 4th gen? my ios is already 6.1.6 how can i recover the older version of facebook app?
     
  19. FatPuppy macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #19
    To download an older version of an app from the app store to any idevice, download that app using itunes on your computer or Mac and than download it again on your idevice but this time it will ask if you want to download the latest available version of that app.
     
  20. MagicHAM macrumors regular

    MagicHAM

    Joined:
    Sep 2, 2013
    Location:
    Australia
    #20
    Download it from the app store on your device that runs iOS6 and the app store will ask you if you would like to download the older version that currently runs on iOS6. That's it you have Facebook. :)
     
  21. venomgt95 macrumors 6502

    venomgt95

    Joined:
    May 8, 2014
    Location:
    Michigan
    #21
    i dont even bother with the facebook app with my iPod. safari is better anyways :p
     
  22. Lancer macrumors 68020

    Lancer

    Joined:
    Jul 22, 2002
    Location:
    Australia
    #22
    I've tried the options here but it always tells me I need iOS7.

    This is for a iPhone 3Gs I just gave to my mum, she doesn't need a new iPhone but wants FaceBook but I have heard iOS7 doesn't work well on the 3Gs?
     
  23. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #23
    iOS 7 can't be installed on the 3GS.
     
  24. Lancer macrumors 68020

    Lancer

    Joined:
    Jul 22, 2002
    Location:
    Australia
    #24
    Well that answers that... but good news everybody one of the tricks did finally work.

    I had to log into Apples App Store with my account on the 3Gs, and it worked. When I tap to download the FaceBook app it tells me I don't have iOS7 but it can DL the last compatible version for iOS6.

    Now why can't this just be the default, regardless if you'd downloaded it before?
     
  25. Xenomorph macrumors 65816

    Xenomorph

    Joined:
    Aug 6, 2008
    Location:
    St. Louis
    #25
    I swear that I downloaded Facebook recently on iOS 6.1.6 on my iPhone 3GS.
     

Share This Page