No more left click

Discussion in 'Mac OS X Lion (10.7)' started by everc, Aug 1, 2011.

  1. everc macrumors newbie

    Nov 8, 2010
    Hi, guys,
    I start to use lion on its official release date.
    However, recently I encounter an issue that the trackpad left click function is missing. When it happens the first time, restart Lion solved the problem. But now the issue persists.
    I thought it was a hardware issue, but it is not. It is the same for my USB mouse as well. The mouse can move, right click, multi-gestures except left click.
    So I conclude it is a software problem, so did this issue happen to any one? What is the solution?

  2. Steve's Barber macrumors 6502a

    Jul 5, 2011
    Left clicking works for me. Never a problem. I also have "tap to click" toggled on in system preferences.

    He probably doesn't care if your right click works because his does as well.
  3. everc thread starter macrumors newbie

    Nov 8, 2010
    Thanks for the replies.
    I found out why.
    Stupid me: I forgot to turn off my magic mouse which is in my travelling bag with lots of stuff.:p
  4. klamse25 macrumors 6502a


    Oct 25, 2009
    Haha I didn't expect that to be the problem! Glad you fixed it. :p

Share This Page