No MP4 audio with QT/iTunes

Discussion in 'Apple TV and Home Theater' started by The.316, Feb 11, 2012.

  1. The.316 macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #1
    I have a few movies that I have converted to MP4 via HB, and I am not getting any audio in iTunes or QT, but when I play the movies in VLC, the audio is fine. Is it a codec problem? Is there anything I can do, or do I have to redo the conversion in HB?
     
  2. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #2
    What kind of audio is it? VLC should be able to tell you. However, most .mp4 video uses .aac audio, so if your file contains .aac audio, it really would be a mystery if no audio plays in QT.
     
  3. The.316 thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #3
    Where does VLC tell you about what kind of audio it is?
     
  4. vwchic87 macrumors newbie

    Joined:
    Feb 17, 2012
    #4
    I have the same issue. I downloaded an mp4 movie and its sound works in vlc. since its audio format is mp3 (at 128kbps) it should work in iTunes, but isn't. this one simply alludes me. help please?
     
  5. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #5
    With VLC, just open the file and go over to Window>Media Information (VLC Screen Shot 1). Then select the Codec Details tab (VLC Screen Sot 2). As far as i know, AAC is more fully supported in the .mp4 container. I don't think Handbrake even has a .mp3 option.

    Or if you have Subler (a very handy app, thanks Subler devs!) it will list all the data streams and type (Subler Screen Shot 1).

    If you wanted, you could just re-encode the audio to aac and use mux the aac audio to your original file and dump the troublesome .mp3 audio track. If you are familiar with Handbrake, load up the original file, pick a simple iPod preset, change the video size down to the smallest it will go (to speed up the encode). Once it is done, open your original file in Subler, delete the .mp3 audio. Then drag the newly encoded video into the Subler window. It will ask you to select what tracks you want to import (all are selected by default, so deselect everything except the aac audio track). Hit ok, then save it. Your original file should now have the original video track and the newly muxed aac audio without an mp3 track. The other video that you sourced the aac audio from can be deleted as you already extracted the audio from it. The reason for doing it this way is to avoid re-compressing the video. Maybe someone has a better way but this is probably the least involved.
     

    Attached Files:

Share This Page