No option for iCloud Music Library in iTunes

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by dcorban, Jul 14, 2015.

  1. dcorban, Jul 14, 2015
    Last edited: Jul 14, 2015

    dcorban macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #1
    I never received a prompt to enable iCloud Music Library. I cannot find any option for it in the preferences. I have the latest version (12.2.1.16). I search the iTunes help and it makes no mention of how to enable or disable it.

    The problem is that I have Apple Music subscription and I have IML enabled on my phone. However, I also have 20GB of music that I had previously synced to the phone. That music is still there and everything works fine on the phone, however, I cannot add more music. In iTunes, when viewing the phone music, it claims that I am using iCloud Music Library, so I should theoretically be able to play any music in my iTunes library. However, I cannot. No music other than what I had on my phone originally is showing. iTunes will not allow me to sync more music.

    My iPad had no music on it. I enabled iCloud Music Library, and now I can see all the music that is on my phone, but nothing from iTunes.

    In short, iTunes does not seem to have IML enabled and there is no option to enable it. What am I missing? I am not going to enable and disable IML every day just to change my playlists and add music. Something isn't working properly.

    edit:
    I found something in the help file that says I should have an option in preferences called "iCloud Music Library checkbox". Instead, I have an option that says "Show Apple Music" in that place. WTF?
     
  2. andreyirra macrumors regular

    Joined:
    Oct 27, 2014
    Location:
    Mexico
    #2
    I don't know if it was a bug or not but the same thing happened to me. I just choose the song view instead of the album view. This way everything is set by columns. I have the status column enabled (the one where it shows with a cloud if it's uploaded, matched or waiting). I selected all the songs waiting to be checked, right clicked on them and selected upload to icloud library.
     
  3. manu chao macrumors 603

    Joined:
    Jul 30, 2003
    #3
    I have two accounts, when I log out of my primary account that option to enable iCloud Music Library doesn't show up. I think this is related to not being able to switch between Apple IDs for 90 days (for certain services, when purchasing stuff from the store that limit doesn't exist).
    [​IMG]
     
  4. flur macrumors 68000

    Joined:
    Nov 12, 2012
    #4
    I had this also on one of my machines. I assume it's a bug. I only have one Apple ID.
     
  5. dcorban, Jul 21, 2015
    Last edited: Jul 21, 2015

    dcorban thread starter macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #5
    I contacted iTunes support and they simply told me to update to the latest version. Obviously, I already have the latest version. Sigh.

    My preferences panes doesn't even have the "iCloud music library" option seen in the above screenshot.
     
  6. dcorban thread starter macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #6
    Fixed the problem myself. I had to "authorize" the computer, despite it already being authorized. The prompt even stated that it was already authorized when I clicked the menu option. So it was a bug of some sort.
     
  7. chakdey macrumors regular

    Joined:
    Aug 9, 2008
    #7
    This doesn't resolve my issue. Any other fix to this?
     
  8. indiekiduk macrumors 6502

    Joined:
    Jul 26, 2005
    Location:
    Glasgow, Scotland

Share This Page