Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

darushah.shah

macrumors member
Original poster
Jun 14, 2016
44
29
I am unable to bind any option to enable two factor authentication is iOS 10 under Settings>iCloud>Apple ID>Password and security. Is this a bug?
 

Attachments

  • IMG_0733.JPG
    IMG_0733.JPG
    95.7 KB · Views: 395

Feenician

macrumors 603
Jun 13, 2016
5,313
5,100
I am unable to bind any option to enable two factor authentication is iOS 10 under Settings>iCloud>Apple ID>Password and security. Is this a bug?

I could be wrong but I think you have to enable it on the apple id webpage
 

deany

macrumors 68030
Sep 16, 2012
2,873
2,086
North Wales
Hi
I think you have to disable two step verification first.

Also I got a message saying I would have to add a six digit pin as not all devises could have two factor authentication. If you get that message ignore it.

If it still doesn't work, have you a mac or iOS 9 devise?
 
  • Like
Reactions: t0mat0

lagwagon

Suspended
Oct 12, 2014
3,899
2,759
Calgary, Alberta, Canada
I am unable to bind any option to enable two factor authentication is iOS 10 under Settings>iCloud>Apple ID>Password and security. Is this a bug?

You have to go on the website and disable Two Step before your phone will show Two Factor.

I could be wrong but I think you have to enable it on the apple id webpage

Nah, Two Factor can be enabled from the device. I did it when the developer beta 2 released (because it's required for Apple Watch auto unlock on macs.)

In fact on my device in Settings was the only place I could enable Two Factor. Website only ever showed me Two Step.
 
  • Like
Reactions: deany and Feenician

darushah.shah

macrumors member
Original poster
Jun 14, 2016
44
29
You have to go on the website and disable Two Step before your phone will show Two Factor.



Nah, Two Factor can be enabled from the device. I did it when the developer beta 2 released (because it's required for Apple Watch auto unlock on macs.)

In fact on my device in Settings was the only place I could enable Two Factor. Website only ever showed me Two Step.
Two step with is disabled. Still unable to see the 2FA option
 

darushah.shah

macrumors member
Original poster
Jun 14, 2016
44
29
I figured you might have had Two Step on because your screenshot shows a recovery email (I thought this was in Two Step only)

Not sure then. I was able to turn on Two Factor without issue in beta 2.
Hey I figured it out, FMIP was not on, so I turned it on and now I am getting option to enable 2FA. Thank you everyone.
 
  • Like
Reactions: t0mat0 and deany
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.