No Picture from Brand New ATV2

Discussion in 'Apple TV and Home Theater' started by Zeneth, Jan 29, 2011.

  1. Zeneth macrumors member

    Dec 18, 2010
    Hello people.

    Well, I have been unable to view anything from my ATV2 unit for last 3 weeks.

    Prior to this, I was able to view the picture on the same TV unit - quite happily....

    I just went to Apple Store and replaced it with a brand new ATV2 unit.

    I get home and try it out - still the same - no picture.

    The LED is on and recognises every time I click and point the Remote COntrol unit at it.

    I have tried all different HDMI ports on my TV and I have tried to unplug the ATV2 unit at differnt times of powering up.

    PLease advise how I can obtain the picture again??

  2. mickbab macrumors 65816


    Sep 13, 2008
    Sydney, Australia
  3. Zeneth thread starter macrumors member

    Dec 18, 2010
    yes, we have tried 3 different hdmi cables.

  4. roidy macrumors 65816

    Dec 30, 2008
    Nottingham, UK
    So if the ATV was working ok with the TV and then stopped working, and a new ATV still doesn't work then it must be a problem at the TV end of the signal chain.

    Does the ATV connect directly to the TV or through an AV reciever?
    Has somebody messed around with any of the setting on the TV?
    Have you tried the ATV on a different TV?
    Whats the make and model of the TV?

    These are all the things I would look at first.

Share This Page