No picture-- just sound in Flash (CS3) video?!?!

Discussion in 'Web Design and Development' started by suburbia, Apr 30, 2009.

  1. suburbia macrumors 6502

    Joined:
    Oct 21, 2008
    #1
    Hey y'all,

    As the title states: No picture, but there is sound in my Flash video:

    - Working with CS3 Flash
    - I converted a mp4 file (26.4MB) into a flv file (only 3 MB?) using Flash CS3 Video Encoder
    - Once imported to stage, tested movie, but all I see is the player controls and hear the audio. No picture.

    Am I doing something wrong, or is the fault of the original mp4 file? Perhaps it's the flv file-- being only 3 MB?

    I suspect the 3MB is the sound (soundtrack) file only, and something is preventing Flash Video Encoder from converting the video.

    I tested another flv file (at 22 MB) and it worked flawlessly. Any advice would be greatly appreciated! Thanks!

    (BTW, like an idiot, I posted this in the DESIGN & GRAPHIC forum, and had no responses [although it had 90 views], so hopefully posting in the ideal forum will get me somewhere.)
     
  2. pelsar macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #2
    have a link?

    somethings to check....open the file in quicktime and export as flv (if you have the pro version)

    does your flv version play in quicktime?

    i assume you made an swf to play the flv...does that swf play in a browser?
     
  3. lucidmedia macrumors 6502a

    Joined:
    Oct 13, 2008
    Location:
    Wellington, New Zealand
    #3
    you can also use VLC player to see if your FLV files are properly encoded... it does sound like an encoding problem
     
  4. suburbia thread starter macrumors 6502

    Joined:
    Oct 21, 2008
    #4
    - Opened in Quicktime Pro
    - Exported as flv file in Quicktime (Flash Encoder via Quicktime).
    - Cannot (do not know how) to play this in Quicktime. But when I move the slider, I DO get frame images.
    - Once encoding is complete, I only get a flv file (2.9MB) that only has sound. No picture.
    - Dragged the flv file into VLC. Only sound, no picture.

    Yes, there was a swf. Imported it into Dreamweaver, tried to preview (in Safari). Only sound, no picture.

    Here's the link to the original video:
    http://www.blogto.com/toronto_fashi...ryerson_school_of_fashion_at_lg_fashion_week/

    I'll upload the downloaded mp4, as well as the flv file if you'd like. Please let me know.

    Many thanks guys for the suggestions-- highly appreciated!
     
  5. pelsar macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #5
    some options....

    dont use MP4...i do my conversions from MP2

    send me a link..i'll see what i can do...
     
  6. suburbia thread starter macrumors 6502

    Joined:
    Oct 21, 2008
    #6
  7. pelsar macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #7
  8. suburbia thread starter macrumors 6502

    Joined:
    Oct 21, 2008
    #8
    This is so cool of you-- thanks so much for taking the time!

    Was it just me, or was the original mp4 file something easy and straightforward to work with?

    I definitely owe you one!
     
  9. pelsar macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #9
    formatting problems...

    you're entering the world of technical problems and formatting....and looking for work arounds.....i couldnt say what exactly the problem was/is, but from experience MP4 is somewhat problematic

    you dont owe me anything, the help i've received here has been tremendous, the least i can do is return the favor to some else here.....
     
  10. suburbia thread starter macrumors 6502

    Joined:
    Oct 21, 2008
    #10
    Whatever you did-- I truly appreciate your time and help pelsar! Thanks again, and if I don't owe you, I definitely hope to return the favor. :)
     

Share This Page