No power G4

Discussion in 'Mac Basics and Help' started by graphicdough, Apr 15, 2007.

  1. graphicdough macrumors newbie

    Joined:
    Apr 14, 2007
    #1
    Short story. I have a G4 Dual 450. It ran fine, then I unplugged it. When reconnecting it did not turn on. I tried a few suggestions made to me and nothing worked. well as far as pushing a few buttons that is. Then out of the blue one day about 2 weeks later I tried and amazingly it turned on. Ran fine. I then had to move it to make room for the computer and once again it does not turn on.
    In short ... any suggestion on what could be wrong?
    Thanks
     
  2. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #2
    Just a guess here: Maybe there is a dodgy power connection and it has to be wiggled in to work :)
     
  3. graphicdough thread starter macrumors newbie

    Joined:
    Apr 14, 2007
  4. SuperCompu2 macrumors 6502a

    SuperCompu2

    Joined:
    Jul 23, 2006
    Location:
    MA
    #4
    Replace the half-sized AA battery inside the case. This might help to power it on every time instead of once in a while. Aged Macs can have these die out after a while, and it needs to have a constant 3.7v I believe to run smoothly.

    Just a suggestion, hope everything works out for you.

    PS. you can find them at RadioShack.
     
  5. graphicdough thread starter macrumors newbie

    Joined:
    Apr 14, 2007
    #6
    Thanks. That was my next step. Guess I just needed conformation.
     

Share This Page