No power on my early 2011 mbp 15"

Discussion in 'MacBook Pro' started by luistmww, Nov 3, 2013.

  1. luistmww macrumors newbie

    Joined:
    Nov 3, 2013
    #1
    First of all hello to everyone (im New to macrumors) i have a problem my early 2011 2.2ghz 15" sudenly stoped charging. to make the storry short. i bought the dc in port twice by accident bought the battery and the charger all oem. same no charging. it turned on with the new battery until it got drained. i tried the smc bypass but no power either. its like the mobo has a blown fuse i cant find anywhere. please help me!!!! im desperate.
     
  2. koban4max macrumors 68000

    Joined:
    Aug 23, 2011
    #2
    u still got warranty via applecare?
     
  3. luistmww thread starter macrumors newbie

    Joined:
    Nov 3, 2013
  4. Treeman574 macrumors regular

    Joined:
    Feb 5, 2011
    Location:
    QLD, Australia
    #4
    I had a similar issue with my 2.0GHz early 2011, randomly crashing then no longer booting. I was unable to charge it once the battery drained. I hope you don't have to go through the same thing I did.

    Apple first replaced the internal power adaptor components. That didn't fix it…
    Then they decided to replace the logic board. That worked for an hour…
    They then gave me a series of lectures about replacing the ram, before telling me that my ram was faulty. Except it wasn't…
    Several logic board replacements later, and apple finally replaced my laptop.

    Finally I found that the AMD GPU was faulty in all the logic boards I had received. Only one employee admitted this was the case while the rest simply dismissed any of my concerns.
     
  5. luistmww thread starter macrumors newbie

    Joined:
    Nov 3, 2013
    #5
    The thing is it still works normally if i plugin another charged battery.
     
  6. sarakn macrumors 6502a

    sarakn

    Joined:
    Feb 8, 2013
    #6
    Are you saying you took put a backup battery in MB, it was able to charge?
     
  7. luistmww, Nov 3, 2013
    Last edited: Nov 3, 2013

    luistmww thread starter macrumors newbie

    Joined:
    Nov 3, 2013
    #7
    No. Basically i dissasrmbled a similar macbook pro. Took the battery out and put it in my mbp. And it worked until it ran out of battery again. And no it didnot charge .
     

Share This Page