No Printer Drivers Found - Epson / Brother

Discussion in 'OS X Yosemite (10.10)' started by GadgetComa, Jul 28, 2014.

  1. GadgetComa macrumors newbie

    Joined:
    Jul 20, 2011
    #1
    I did a clean install of the public beta on my 2009 13" MBPro. When I tried to install the printers, it said I had to download from the vendor. My printers are a Brother HL-5250DN, Epson Stylus Workforce 635 and Epson Stylus Photo R3000. All had drivers included by Apple under Mavericks. I wonder if this means that there's enough of a change in the printing subsystem that old drivers won't work? That doesn't bode well for older printers that the vendor may not update drivers for.

    Anyone else find this?
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    I think it is a little early to expect updated vendor files for beta OS. What you ran across is not unusual. Give it some time. The vendor may issue an update.
     
  3. joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #3
    I had a similar message couple days ago, then last night, opened the device and my printer drivers installed, correctly, scanner too! HP Photosmart Prem C410
     
  4. GadgetComa thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #4
    I realize that vendors aren't going to have updates out yet. I'm used to beta testing. I'm just surprised that there are no drivers at all. I would expect some to be available unless something in the OS changed enough to require the majority of vendors to update their drivers. Or, is it Apple's position that the drivers don't get included even if they could work until the vendor says so?

    ----------

    Well, I went ahead and tried again today and there are drivers for all of them. So I guess, there might have been some issue preventing them from showing up. Mind you, I'm not complaining. This is life with beta software. Just curious. Of course, this is part of the adventure too. ;)
     
  5. Fuchal macrumors 68020

    Joined:
    Sep 30, 2003
    #5
    I got the same error for my Canon - downloaded the Canon drivers from apple.com/support/downloads - and was back in business.
     

Share This Page