No Printer Selected - MacBook Pro - 10.6 Snow OS X - Canon MP990 AIO

Discussion in 'Mac Accessories' started by Hooksta, Jan 7, 2010.

  1. Hooksta macrumors member

    Joined:
    Jul 19, 2008
    #1
    I am very new to Mac (two weeks now) and I was having the smoothest of installations of my new Canon MP990 AIO printer. I carefully followed the instructions, went to Canon's website to get the proper drivers for this printer (because the disc does not have software for 10.6). My wireless network found the printer no problem. Heck even the MacBook found it and installed it no problem...or so I thought.

    Every time I try and print I see "No Printer Selected" and then when I try and repeat the step of selecting my new Canon it says you already have this printer set up and is asking would I like to set it up again. I can't seem to find where the printer software is even installed on the MacBook.

    Afterwards I tried installing the CD on my PC laptop. Just as with the MacBook, smooth and easy install...easier because I didn't have to download. Anyhow the PC is printing really easy. I am disappointed because all the reviews I read about this printer made it sound like a monkey could get it going. I've spent over two hours and not feeling very good about being dumber than a monkey.

    Can anyone help?

    Thanks!
     
  2. Hooksta thread starter macrumors member

    Joined:
    Jul 19, 2008
    #2
    EXTRA NOTE: I see two listings of the Canon MP990 when I click on the Apple symbol, select "About this Mac", then "More Info," and once I select on Printers.
     
  3. Hooksta thread starter macrumors member

    Joined:
    Jul 19, 2008
    #3
    Amazing! Not often one can be brand new to the MacWorld and stump the entire MacRumors community with their first question to the board. :p

    I finally solved the riddle. I can't recall the steps but I stumbled around until I found a way to make the Mac go seek out the software that the MacBook had already told me was successfully installed. It was really strange too, because each time I was trying to select the printer I couldn't. But if I wanted to add a printer it would ask me if I wanted to make a copy of the printer. So on one hand it couldn't find it and on the other it would say "why are you wanting to duplicate it?"...all the while everything said "You have successfully installed this printer." Strange for sure.

    My Mac experiences have been good outside of this.
     

Share This Page