No printers are available after 10.9.4 upgrade, help

Discussion in 'OS X Mavericks (10.9)' started by compute, Jul 4, 2014.

  1. compute macrumors regular

    Joined:
    Jun 11, 2013
    #1
    Hi everyone,

    I tried to print something today on my xerox printer and first it gave me the message that "the printer is offline" after trying out a few things i couldn't get the printer to work, so i decided to desert the printing system and re-install the drivers of the printer again hoping this will fix the problem.

    On the contrary after installing the drivers the printer doesn't even show up in the "printers & scanners " dialogue box (system preferences - printers & scanners"

    It just says "no printers are available Click Add (+) to set up a printer"...when i try and do this there is nothing to add.

    When i try to print a document i get the message "you need to install a printer...

    Does this have to do with the 10.9.4 upgrade i did 2 days ago or is there probably another problem? Any other steps/tips i can try out to make the printer work again?

    All help is really appreciated
     
  2. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #2
    - Power cycle the printer
    - Power cycle modem and / or router
    - Test another device with the network printer
    - Make sure you have the newest drivers
    - Try an older driver if newest driver is installed
    - Confirm network settings on printer
     
  3. compute thread starter macrumors regular

    Joined:
    Jun 11, 2013
    #3
    What do you mean with "power cycle the printer"?

    I have the newest drivers and tested out the older ones, no luck...
    My printer is only conected with usb its not in a network
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    unplug and replug the cable between the computer and the printer. THEN try adding the printer.
    also... reboot the mac. reinstall drivers...
     
  5. compute thread starter macrumors regular

    Joined:
    Jun 11, 2013
    #5
    I tried this but here's the thing....the printer is not even recognised, when i try and install the driver i get the message saying the driver is installed successfully...yet the printer doesn't show up under printers & scanners...when i try to print a document i get the message saying i need to install a printer first.

    Few weeks all worked great...big question is if this is driver related or maybe another problem.
     

Share This Page