NO PUSH MAIL in iCLOUD says APPLE REP

Discussion in 'iOS 5 and earlier' started by insocal, Oct 18, 2011.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    I switched TWO MobileMe accounts over to iCloud. Hadn't been receiving any mail via PUSH on the iPhone. Am chatting with a Rep right now who said that PUSH MAIL is not in iCloud! What?! I'd have never switched over from MobileMe had I known this...at least not until it expired in June.

    Is it an iOS 5 thing? Because it pushed fine before the iCloud transition. Even in iOS 5.

    Has anyone else heard this? Really unfortunate news if the Rep is correct.

    From the Chat:
    "Unfortunately, there is not a push setting in iCloud."
    "Not sure why they changed this setting. I can direct you to the Apple feedback page. We place a high priority on customer feedback here at Apple, and our products and services evolve as a direct result of it. You would be able to leave feedback on MobileMe here, whether it be positive or negative. http://www.apple.com/feedback/mobileme.html"

    I'm really hoping she's wrong...
     
  2. Don Kosak macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #2
    Are you sure about this?

    The settings for iCloud do say "PUSH" on the device.
     

    Attached Files:

  3. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #3
    You left off the disclaimer at the bottom of that screen.

    "If Push is not available, the Fetch schedule will be used."
     
  4. insocal, Oct 18, 2011
    Last edited: Oct 18, 2011

    insocal thread starter macrumors regular

    Joined:
    Jul 31, 2007
    #4

    I know, I've got mine set to PUSH also. It doesn't make any sense. The only way messages seem to get PUSHed now is if the MAIL app is actually open. When it was MobileMe, mail would be PUSHed all the time...whether the app was open or not...and a notification would show up. Or the MAIL would at least be there when you opened the app, turned on the phone, etc.

    Not the case now...

    Don,
    I see you have a .Mac account still and have it set to PUSH. Are you noticing that mail arrives for that account at a different rate than the iCloud account? I've switched both of my MobileMe accounts over so I can't test that option. Just curious. Thanks!
     
  5. nomad01, Oct 19, 2011
    Last edited: Oct 19, 2011

    nomad01 macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #5
    Sounds like a load of cr*p to me. Check out the icloud page...

    http://www.apple.com/uk/icloud/features/calendar-mail-contacts.html?cid=mc-uk-g-clf-email

    It says "When you set up iCloud, you get a free me.com email account. iCloud automatically pushes new email messages to all your devices, so your inbox is up to date everywhere you check it. And iCloud keeps all your folders in sync, no matter which device you’re using."

    Having said that, there are issues at present and it's being discussed on Apple's support forums.

    Seems to work some of the time and not others. Annoying and I hope apple sort it soon.

    Let them know there's a problem here:
    http://www.apple.com/feedback/icloud.html
     
  6. NeroAZ macrumors regular

    Joined:
    Jun 23, 2009
    Location:
    Phoenx, AZ
    #6
    I am having some issues with my iPhone not getting mail as well. my iPad does so I'm not sure of the problem. I might do a restore and see if it fixes the problem.
     
  7. Don Kosak macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #7
    Actually, I upgraded that .Mac account to iCloud. (It was a .Mac, then a MobileMe account prior to upgrading.)

    Both of the accounts ~seem~ to get email right away. I'll do a couple tests (like CC'ing both my iCloud accounts and seeing if the upgraded MobileMe account acts differently than the "iTunes AppleID" created iCloud account.

    It's weird that it works for some people. I'll also try changing my "Fetch" settings to "Manual" and see what happens. (if Push is broken, I shouldn't get messages with Fetch set to Manual...)

    I'll let you know what I find out.
     
  8. Don Kosak macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #8
    PUSH Test Result

    Okay,

    I turned "FETCH" to Manual. Set my iPad and iPod Touch on the table with the home screens up.

    I made an email from GMail to both my old .Mac account (upgraded to iCloud) and my brand new .Me account (created from my iTunes Apple ID). To be clear, they are two separate iCloud accounts, one created on the 7th, and one created on the 12th.

    I hit send in GMail, and counted. 1.. 2.. 3.. 4..

    On 4 both iPad and iPod Touch chimed and the notification and summary of my test message with displayed (twice) on each screen.

    Both devices simultaneously received 2 messages (as they are both setup for both iCloud accounts.)

    So, with Fetch turned off, and the near instant receipt of messages -- I am 99.99% sure Push is working for my iCloud accounts.

    I believe my account is on server "P03" if that makes sense to you. I'm setup as an iCloud account on the device (not as an IMAP account as some people have done to make iCloud mail work with iOS 4.x)

    I'm unsure as to why this isn't working for some people.
     
  9. nomad01 macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #9
    And this was done without the Mail app running in the background?
     
  10. donnaw macrumors 65816

    Joined:
    Apr 19, 2011
    Location:
    Austin TX
    #10
    I have an ipad2 and my grandkids have an ipad1. I updated both and set mine up with my Apple ID and set theirs up with a different iCloud ID. I sent a test email from mine to theirs making sure the mail app on theirs was closed and not sitting in the multitasking area. The email went through immediately. I then did the same thing going the other way and it worked too. Then I sent them an email from my gmail account and it worked too. So mine seems to be working just fine.
     
  11. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #11
    One of the reasons I switched to an Exchange Server was that MobileMe had often problems with push, especially with calendar...It seems that Apple still hasn't solved such issues in iCloud. They should just use the best Server technology for that: Exchange Server.
    Everything else doesn't work as well...
     
  12. starstreak macrumors 6502

    Joined:
    Dec 5, 2004
    #12
    Amazing I've been saying this for the past few days and only now people are responding to this.

    I had a me.com account that was moved to icloud. Iphone 4 with IOS5. Unless I have the mail app running in background, I won't get my mail. Unless it's my gmail account. That works. Push doesn't work right. And fetch doesn't ether. I've had my mail app closed once for a few hours and never got any mail. And my fetch was set for 30mins.
     
  13. Don Kosak macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #13
    Fetch set to Manual.

    iCloud set to Push.

    Bring up multitasking bar, killed off Mail (just to be sure it was truly unloaded).

    On my iMac, I went to Mac email, sent a message from GMail to my iCloud accounts. (both of them again.)

    Message Notification appeared on both iPad (mail killed) and iPod Touch (mail running) while the "swoosh" sound was still playing.

    2 seconds later, a second notification appeared. (one iCloud account was faster by 2 seconds on this test. Can't tell which one as they both have same timestamp etc.)

    iPad was "on" at the home screen.

    iPod Touch was "off" and charging (at the home screen, but off)

    Neither are Jailbroken (which sometimes messes up push notifications)

    So I am 100% positive that for my two devices, on my iCloud accounts, with mail running or mail killed that iCloud works.

    ----------

    Under "Settings" > "Notifications" I have the following settings for Mail:

    Notification Center: ON

    Show: 5 Unread Items

    Alert Style: Banners

    Badge App Icon: ON

    Show Preview: ON

    View in Lock Screen: ON

    What are your Notifications set to?
     
  14. starstreak macrumors 6502

    Joined:
    Dec 5, 2004
    #14
    I dunno what's up. I tried setting my iphone Fetch to manual. Closed my mail app. sent an email from my home computer. Wait a minute. Never got it. Opened my mail app and the email came in. BTW, I set my notification to the same as yours. It was set to 10 unread and preview was off.

     
  15. donnaw macrumors 65816

    Joined:
    Apr 19, 2011
    Location:
    Austin TX
    #15
    You know I've been reading these for a couple of days and it kind of seems that the folks having the issues have moved from a MobilMe account. Anyone having these issues that created new accounts or had a .MAC account?
     
  16. Don Kosak macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #16
    I just set Fetch to manual just for testing. I don't think it has anything to do with the problem. (I just turned off Fetch because I wanted to make sure only PUSH was going on.)

    I think the Notification settings are important if the Mail app isn't running. That's why I posted my settings.

    I figure either:

    A) I'm working because I'm one of some number of people with working iCloud accounts and Apple is probably shaking out bugs on other accounts/servers.

    B) My settings are somehow different than other people.

    In the "A)" case, there's not much we can do. I assume if it works for some people, that it's just a kink, and Apple will fix it soon.

    In the "B)" case, I figured since mine was working, I'd post my settings and see if it helped.

    I feel bad for folks having problems. Hopefully I helped a bit with these posts.

    ----------

    I tested on my old .Mac account (that was upgraded a couple years ago to MobileMe, and then upgrade last week to iCloud). Push worked okay (see the posts above. I used the xyz@mac.com form of my email address by the way, but it didn't seem to matter.)

    I also tested on my iTunes account. It was one of the really early ones with no email address, just a plain word. I upgraded it earlier in the week to a second iCloud account as I'm eventually going to move everything under one account. Push worked okay on this account as well.

    I tested by CC'ing both iCloud accounts from Mac Mail on my iMac.
     
  17. monkeygadge macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #17
    I had this issue last week on the day after release, then push worked fine over the weekend. It stopped again yesterday and hasn't worked since.

    I'm on the p99 server and I migrated from MobileMe.
     
  18. starstreak macrumors 6502

    Joined:
    Dec 5, 2004
    #18
    Ok so I tried a few more tests.
    I have push "off" and fetch set to 15mins. I close the mail app. I get the message I sent around 12-15mins later.

    I have push "on" and fetch set to 15mins. I close the mail app. I waited 20mins. NO mail. I open the mail app and the email comes in.

    I have push "on" and feth set to manual. I close the mail app. No mail. Only once I open the mail app does the mail come in.

    How do I check what server my me.com was on?

    SO... At this point I can make sure I have the mail program in background running to get my push. Or drain battery even faster by turning "off" push and leaving fetch ON to 15mins.
     
  19. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #19
    I get @me.com email instantly. The only thing not working (as MobileMe) is "read" updates to my iDevices from iCloud.
     
  20. starstreak macrumors 6502

    Joined:
    Dec 5, 2004
    #20
    Not sure what's different but earlier today (about 4 hours ago) I had a heck of a time getting "find my iphone" to work. Just now I tried it, and put "pushed" my text to the iphone without issues. With and without the mail app. BUT I only got the email (the one saying that I used that program) sent to my iphone only when I turned on the mail app.
     
  21. big samm macrumors 65816

    Joined:
    Oct 27, 2008
    #22
    Same problem here, before migrating everything was fine with push email, now i have to go in the app and manually refresh it so i can receive my emails... Very annoying!! I think their severs can't handle the traffic yet!
     
  22. Lehigh45 macrumors member

    Joined:
    Jul 10, 2009
    #23
    Until this matter is resolved, I'm forwarding my MobileMe/iCloud account to the Yahoo! account I just created.

    A workaround I shouldn't have to do but it'll do for now...
     
  23. Apfeldirektsaft macrumors member

    Joined:
    Oct 19, 2011
    #24
    I have the same problem. Migrated from MobileMe and now I only get Push Mail when the Mail App is running in the background.
     
  24. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #25
    I never had a MobileMe account, so I created my @me.com account once I installed the iOS 5 GM. I just tested the push feature after browsing this thread, and my messages are arriving instantly to my phone, but oddly enough, they aren't on my iPad.
     

Share This Page