MP 1,1-5,1 No recovery partition with Catalina using DosDude1's Patcher

Peet_B

macrumors demi-god
Original poster
Jun 10, 2019
42
12
Netherlands
I've got Catalina running on my 4,1(5,1) for a few months now, and has been working without much trouble. Though recently I tried to disable SIP via the recovery partition (was unnecessary because using DosDude1's patcher automatically disables SIP) and found out that my recovery partition was non-existent. I can see my main drive being partitioned into 5 partitions, and one of them being the recovery, but there is absolutely no way I'm able to access the recovery partition... I attempted booting into recovery via a bootable USB, and this worked but gave me no rights to change anything whatsoever.

So my question is, how do I get a working recovery partition... Is there a "safe" way of installing Catalina on my 4,1(5,1) without using the DosDude1 patcher? I'm kinda tired of updating the OS by completely reinstalling a new copy of Catalina every time, even though it works... I'm also unable to use my stock GT120 in combination with my RX580 for some stupid reason, when they're both in the machine neither of them work... That means when I need access to a bootscreen, I have to take out my RX580 and insert my GT120, and when I'm finished I'll have to do it all in reverse...
 

MacUser2525

macrumors 68000
Mar 17, 2007
1,980
305
Canada
Try using Carbon Copy Cloner to duplicate the drive on another it will usually offer to create the partition for you when it is not present. Also are you making sure you let it go long enough to get to the recovery partition? I have seen many say it can take forever to get to it with the non-efi cards in the system. There is a flag the no compatibility check I think it is that allows for you to run it without the patcher. There is a large thread here started by tsialex that has all kinds of this information in it you may want to search for.
 

Tsvetan Petrakiev

macrumors newbie
Feb 18, 2020
1
0
Hi! I installed OSX Catalina with patcher and it worked fine for several months. The system than crashed and now i need to recover from a time machine back up. The propblem is that the MAC does not longer recognise its last back up. It indicated that the back up was made from another computer. Anyone had that problem? Is there a way to use the existing back up and recover the system?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.