No reserve battery notification

Discussion in 'MacBook' started by cecilworsley, Mar 23, 2010.

  1. cecilworsley macrumors newbie

    Joined:
    Apr 16, 2008
    #1
    I have a MacBook (2 GHz, 2GB RAM) OSX 10.6.2. The problem that I have with it is that I will not tell me when it is on reserve battery, so I shuts down with out me knowing. The computer has reported that the battery needs to be replaced soon, but I can't see how that would affect the battery notification. Also all of the energy preferences have been set back to default so there is nothing in the preferences that would be affecting this. Let me know what the problem is, thanks for all the help in advance.
     
  2. slpdLoad macrumors 6502a

    slpdLoad

    Joined:
    Jun 10, 2009
    #2
    If the battery is defective, as you say it's reported that it needs to be replaced, then it may not be informing the computer when it is low on juice. If that's the case, give AppleCare a call and they should set you up with a new battery. Or, if you're out of warranty, try a new battery and see if that fixes the issue.


    Quick things to try before replacing the battery:

    Reset the power management (SMC):
    http://support.apple.com/kb/HT3964?viewlocale=en_US

    And to reset the PRAM:
    http://support.apple.com/kb/HT1379?viewlocale=en_US
     
  3. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #3
    Probably a dying battery
    When the battery is near death the Mac's (or the battery logic's) ability to predict remaining charge goes wrong. So it goes from loads left .... to nothing much quicker than the Mac predicts.
    I think "replace soon" or whatever on System Profiler is a euphemism for dead battery!
    Try what the previous poster said though, worth a try
     
  4. cogsinister macrumors 6502a

    Joined:
    Aug 24, 2006
    Location:
    Fredericton NB Canada
    #4
    I got a replacement battery after 13 months from Applecare, mine started doing the same as the OP's.....took a good hour or more on the phone to Apple, but it worked......
     

Share This Page