No response - build-in keyboard and trackpad

melchiorsen

macrumors newbie
Original poster
Feb 25, 2011
19
3
Denmark
Recently I've been experiencing unresponsive build-in keyboard and trackpad. The only key working is the power off/on.

I think the problem is related to Bluetooth module in the MacBook Air.

The Bluetooth symbol in the menu bar becomes crossed over with a sawtooth horizontal line and the keyboard and trackpad stops working.

No Bluetooth devices are paired or connected to the laptop.

External USB keyboard and mouse does not respond either.

I've deleted all Bluetooth preference files on the computer and rebooted the machine, nothing helps. There are no Bluetooth devices connected to the computer.

It doesn't help upgrading to OS X 10.8. I've tried and the problem is the same.

This is becoming so frustrating, what can I do about it?

-------

MacBook Air 11" (2011), OSX 10.7.5
 

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
My MBP's keyboard and trackpad has suddenly started to stop responding too, I think the issue is related to USB devices, since when its happened twice, both times I have had my USB drive plugged in. Has anyone else had this problem?
 

jbzcar

macrumors regular
May 11, 2012
211
0
My MBP's keyboard and trackpad has suddenly started to stop responding too, I think the issue is related to USB devices, since when its happened twice, both times I have had my USB drive plugged in. Has anyone else had this problem?
Yeah, there is another recent thread about it happening when USB devices are plugged in. The OP in that thread said it was resolved with an SMC/PRAM reset.

It happens to my Air when I plug in my external hard drive. Gonna reset mine later today when I have a chance.
 

Xcallibur

macrumors 6502a
Jul 24, 2011
515
1
Manchester
Yeah, there is another recent thread about it happening when USB devices are plugged in. The OP in that thread said it was resolved with an SMC/PRAM reset.

It happens to my Air when I plug in my external hard drive. Gonna reset mine later today when I have a chance.
Arh okay, thanks for the tip.
 

melchiorsen

macrumors newbie
Original poster
Feb 25, 2011
19
3
Denmark
The issue was not related to USB devices plugged into the laptop.

After af force power shutdown (holding the powerbutton down for several seconds) the laptop is now caught in a boot-loop.

There's no response from the keyboard so it is not possible for me to do a safe restart (Shift-Power) neither a SMC reset (Shift-Control-Option-Power) or a PRAM reset (Command-Option-P-R)

Now I'm stuck with a laptop in boot-loop all due to a new Apple operating system :mad:
 

jbzcar

macrumors regular
May 11, 2012
211
0
The issue was not related to USB devices plugged into the laptop.

After af force power shutdown (holding the powerbutton down for several seconds) the laptop is now caught in a boot-loop.

There's no response from the keyboard so it is not possible for me to do a safe restart (Shift-Power) neither a SMC reset (Shift-Control-Option-Power) or a PRAM reset (Command-Option-P-R)

Now I'm stuck with a laptop in boot-loop all due to a new Apple operating system :mad:
Try a USB keyboard, perhaps?
 

Cynicalone

macrumors 68040
Jul 9, 2008
3,212
0
Okie land
Go to the Apple store and let them deal with it.

Most other choice require you to be able to hold down various keys on boot. With no keyboard that isn't an option.
 

vicky393

macrumors newbie
Jan 26, 2013
1
0
exactly same problem

I am also experiencing the same problem with bluetooth off , keyboard and trackpad not working , no usb working.

Please let me know if you have fixed the problem by now.

I will be very thankful to you.
 

sangeetjass

macrumors newbie
Jun 22, 2013
1
0
Facing this exact problem, where bluetooth goes on and off, and keyboard freezes

Please suggest a solution.
Recently I've been experiencing unresponsive build-in keyboard and trackpad. The only key working is the power off/on.

I think the problem is related to Bluetooth module in the MacBook Air.

The Bluetooth symbol in the menu bar becomes crossed over with a sawtooth horizontal line and the keyboard and trackpad stops working.

No Bluetooth devices are paired or connected to the laptop.

External USB keyboard and mouse does not respond either.

I've deleted all Bluetooth preference files on the computer and rebooted the machine, nothing helps. There are no Bluetooth devices connected to the computer.

It doesn't help upgrading to OS X 10.8. I've tried and the problem is the same.

This is becoming so frustrating, what can I do about it?

-------

MacBook Air 11" (2011), OSX 10.7.5
 

fzzahedi

macrumors newbie
Apr 15, 2014
1
0
Hi, I'm facing the exact same problem with my MacBook Air mid-2011 where my trackpad and keyboard dies and bluetooth has the buzzsaw symbol over it.

Anyone figured out what the problem was?

Thanks guys.
 

voigtstr

macrumors member
Jan 31, 2008
88
1
Hobart, Tasmania, Australia
I'm getting the same thing sometimes.
Other times after boot it will just ring the chime every 5 seconds until its powered off.
This current time (I'm typing this on the wife's computer) the bluetooth mouse worked but then I couldn't type my password as the built in keyboard isn't responding.
No USB devices are plugged in.
I've plugged in an external Apple keyboard, but then noticed that the mouse has stopped responding. Time for a reboot!
External mouse left port works. External mouse right port does not. External mouse in the USB on the keyboard works!
Might try a reboot with PRAM reset alt option P R
Which hasn't fixed the keyboard...
 

syrus_op

macrumors newbie
Feb 29, 2016
1
0
The issue was not related to USB devices plugged into the laptop.

After af force power shutdown (holding the powerbutton down for several seconds) the laptop is now caught in a boot-loop.

There's no response from the keyboard so it is not possible for me to do a safe restart (Shift-Power) neither a SMC reset (Shift-Control-Option-Power) or a PRAM reset (Command-Option-P-R)

Now I'm stuck with a laptop in boot-loop all due to a new Apple operating system :mad:
I experienced this same problem after upgrading to El Capitan 10.11.3. Got it solved by booting in safe mode (holding shift key while booting), and resetting the disk permissions.
I referred to this link to resolve the boot loop problem- https://techtalktone.wordpress.com/2013/09/16/stuck-in-boot-loop-on-the-mac/

to reset disk permissions - http://osxdaily.com/2015/11/04/verify-repair-permissions-mac-os-x/
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.