HomeKit No Response from HomeKit devices only with Apple and Home app?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by Paco II, Feb 15, 2017.

  1. Paco II macrumors 65816

    Joined:
    Sep 13, 2009
    #1
    Came home to find that my lights weren't on. Tried to manually enable via Control Center and Home app but 'no response'. Opened the device maker's native app, and no issue turning on lights. What gives? Any suggestions?
     
  2. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #2
    So after trying a few things, went to last resort and unplugged and replugged and now working. The annoying thing is that the app maker's app always worked. What's the deal with Apple's connection?
     
  3. hokiepokie07 macrumors 6502a

    Joined:
    Jun 20, 2009
    #3
    Are you connected remotely to your AppleTV? Check to make sure it says AppleTV: Connected. In the Home app, click the arrow on the top left corner and make sure your AppleTV says connected.
     
  4. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #4
    This was on the same wifi network. I do use an Apple TV as a hub, and it did say connected in the settings, but that should be irrelevant in this situation. On the same network the Apple TV should not be part of the equation.


     
  5. Briankeith82 macrumors newbie

    Briankeith82

    Joined:
    Nov 12, 2008
    Location:
    CT
    #5
    I'm having a similar issue. If someone mistakenly uses the old light switch, the light or room within the iOS control center reverts to "no response". However... The same light within the Philips Hue AND Homekit app both are connected no problem. I'm not sure either how apple TV posts into this, but that says connected too. So it's just the control center that says no response, and continues that way no matter what I do; unless I completely remove homekit setup altogether and start over.
     
  6. Veranth macrumors newbie

    Joined:
    Aug 19, 2018
    #6
    Has the "No Response" problem been addressed? I'm new to HomeKit and have installed a bunch of devices from Hue, LifX, and iDevices. They and my iPod are all on the same WiFi network and I'm only trying to use them locally, not remotely so I don't think I need a hub. All the devices work fine with the Home app when first installed, but after an hour or so they all say "No Response" with the Home app, but all work with their maker's apps. Per advice from the accessory makers, I've found that turning WiFi on my iPhone off and back on fixes the problem but only for a short period of time. This is a preposterous work-around, since when I walk into a room and want to turn on the light I don't want to waste my time going to settings and turning off and on WiFi every time. Since the manufacturer's apps always work, and the manufacturer app is using all the same hardware/router/WiFi as the Home app, the problem is clearly with Apple software/firmware. What good is HomeKit if you have to use the individual apps? Is there a real fix?
     

Share This Page