"No service" always there on Verizon 3G model

Discussion in 'iPad' started by inspiritu, Mar 13, 2011.

  1. inspiritu macrumors newbie

    Joined:
    Apr 20, 2010
    #1
    Got the Verizon 64GB 3G model on launch day and absolutely love it.

    But one thing I am not fond of at all is that the words "No Service" are at the top of the screen at all times (next to the wireless signal indicator).

    On my first-generation iPad, when I wasn't using 3G, the word "iPad" appeared next to the wireless signal indicator.

    I have checked in Settings that the wireless signal is turned off, and I haven't signed up for service yet.

    Does everyone else that has this model have these same words at the top? And any way to make them go away?

    Thanks!
     
  2. mctheriot macrumors regular

    mctheriot

    Joined:
    Nov 2, 2007
    Location:
    McHenry, IL
    #2
    I've got the same unit as you. With my wifi turned off (i've not activated it yet) it just says iPad at the top.

    Mark
     
  3. ovrlrd macrumors 65816

    ovrlrd

    Joined:
    Aug 29, 2009
    #3
    Turn off Cellular Data under settings, that will make it look 100% like a Wi-Fi iPad in the status bar.

    I would be concerned about the No Service thing though because, on the AT&T ones at least, there is a little signal indicator in the top left even if you aren't signed up for data. Maybe the Verizon one works differently though, but the reason it works like that on AT&T is so you can sign up anytime, even without an active Wi-Fi connection.

    Either you get no Verizon service where you are at or the Verizon iPad works differently.
     
  4. ElBerserko macrumors member

    Joined:
    Jun 30, 2007
    #4
    I had to turn off cellular data and flip Airplane mode on and off to switch from "No Service" to "iPad". I find it odd that mine also displays No Service before signing up for 3g service. If I attempt to sign up for service without WiFi enabled it doesn't work.

    I thought we could sign up for service wherever we needed to without an existing internet connection...I've done hard resets, reset the network settings, and I cannot get it to display anything but no service.

    I have no intention of signing up right now, but I want to know it will work in the future if I need it. Is this the normal behavior on Verizon iPads?
     
  5. M87 macrumors 65816

    Joined:
    Jul 18, 2009
    #5
    I just signed up for Verizon 3G while driving down the road. Works exactly like my old AT&T one did. Are you sure you have good Verizon coverage where you are?
     
  6. ElBerserko macrumors member

    Joined:
    Jun 30, 2007
    #6
    I live in a metropolitan area and had a Verizon phone before switching to the iPhone and never had reception issues in this area. There is no reason why I shouldn't get service where I am at.
     
  7. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #7
    My Verizon one acts just like my AT&T iPad 1 did.
    Other than making sure 3G cellular data is turned off, not sure what else is the problem.

    Try DFU'ing it and restoring.
     
  8. ElBerserko macrumors member

    Joined:
    Jun 30, 2007
    #8
    I ended up doing a full restore which seems to have fixed it.
     
  9. RadicalxEdward macrumors 6502

    RadicalxEdward

    Joined:
    Mar 8, 2011
    #9
    glad to hear you fixed it. Wish that same thing worked with the iphone. I have to have airplane mode on (and manually turn wifi on) in order for it to not say no service. expecting my ipad 2 this week and it's nice to know I won't have to see that stupid no service thing when i'm not signed up for data.
     
  10. thebubbatex macrumors regular

    Joined:
    Mar 8, 2010
    #10
    Dude, come on.....
     

Share This Page