No service even after unlock

Discussion in 'Jailbreaks and iOS Hacks' started by helloviet, Feb 3, 2011.

  1. helloviet macrumors newbie

    Joined:
    Feb 3, 2011
    #1
    iPhone 3gs, iOS 4.1, baseband 6.15.00.

    I'm trying to unlock it for T-Mobile.

    I have unlocked it correctly and jailbroke it correctly.

    I jailbroke it using redsn0w rc8, or the latest one. I then went into cydia, did the necessary upgrades, restarted my phone, turned OFF 3g, kept cell data on, and then installed Ultrasn0w 1.2 via Cydia. I rebooted my phone and the service says "Searching..."... and I can't find any service. Help pleaaaaaaaase
     
  2. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #2
    Reboot, respring, reinstall ultrasn0w until it works. Sometimes this must be done a few times.
     
  3. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #3
    If you are using T-Mobile SIM, make sure you turn the "Enable 3G" to off position. Otherwise, the phone keeps saying "Searching".
     
  4. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #4
    I will try this, thanks so much for the fast response.


    It is off, haha. It's been off before I installed ultrasn0w
     
  5. Steven Jobson macrumors regular

    Joined:
    Jan 13, 2011
    #5
    When this happened to me, I did what the second poster did. The only difference is that I thought of that solution myself.
     
  6. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #6
    What's the latest version of Cydia?

    I restored my iphone but redsn0w kept crashing when I tried to jailbreak it, so I used limera1n. When I installed cydia, it was version 1.0.3222-73 and it won't update
     
  7. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #7
    Latest version is 1.0.3366-1
     
  8. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #8
    how many times do I do this

    o.o

    so I've rebooted, resprung, ultrasn0w, resprung, reboot, and did the same thing for the past 30 minutes o.o
     
  9. Steven Jobson macrumors regular

    Joined:
    Jan 13, 2011
    #9
    Cydia version is irrelevant here, and you have to update Cydia manually.
     
  10. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #10
    You can use Cyder 2 to load ultrasn0w directly into your phone. I have tried that few times and it worked.

    May be try that way and see if it works.
     
  11. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #11
    Apparently, it sometimes takes up to 15 mins to find service for the first time after installing ultrasn0w and inserting the sim. sometimes it also helps to insert the new sim during the boot up process.
     
  12. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #12
    I might look into this more, thanks.



    I don't have access to another sim right now, and hm.. 15 minutes? sigh. that's weird.
     
  13. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #13
    Are you sure the SIM is installed in the correct direction and fully seated?

    Are you sure ultrasn0w is installed?

    Are you sure 3G is still turned off?

    Remove and reinstall the SIM if you must. While I've had to reboot, respring, reinstall several times, I've never had the difficulty you are experiencing.
     
  14. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #14
    Positive the sim is in - otherwise it would say "No Sim"

    Positive ultrasn0w is installed - has a check next to it and the options "Reinstall" and "Remove"

    I do replace the sim every once in a while because I'm texting people on my other phone
     
  15. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #15
    Every time you take the SIM out you create the potential to have to keep repeating these steps. Seems like this is your problem.
     
  16. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #16
    Hm. Well, I took it out every like 30 minutes to respond. But that only happened twice. The second time I just kept it out and texted from my other phone.

    Would you mind giving me like step by step instructions on what to do, or does it sound like what I did was right?
     
  17. helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
  18. Steven Jobson macrumors regular

    Joined:
    Jan 13, 2011
    #18
    You disgrace Vietnamese people.

    90% of the time when you remove your SIM from the unlocked iPhone you'll have to do these steps again.

    1. Have the phone on, normal, with SIM in and you'll see No Service or whatever.

    2. Take the SIM out, wait 10 seconds, put the SIM back in. It should still say No Service or whatever it says.

    3. Turn the phone OFF. Take the SIM out when the phone is OFF and wait 10 seconds and put it back in.

    4. Turn the phone back on, should be Searching...

    5. Wait a few minutes and then it will say T-Mobile
     
  19. helloviet, Feb 5, 2011
    Last edited: Feb 5, 2011

    helloviet thread starter macrumors newbie

    Joined:
    Feb 3, 2011
    #19
    okay, well how long is it supposed to "Search" before it says tmobile?

    because it hasn't changed for a while.

    also, if you didn't read, I never took out the sim while I was respringing and reinstalling ultrasn0w until like 30 minutes after

    oh, it changed, it now says no service
     
  20. Shiggity macrumors newbie

    Joined:
    Oct 8, 2007
    #20
    I'm glad you were banned. Not only did you not solve the problem, you were unnecessarily rude.
     
  21. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #21
    Did you know you response to an old thread? In addition, he has been banned, so he will not see your message. :D
     

Share This Page