No Service for T-Mobile on 3GS w/ 4.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by LongbowFoSho, Dec 28, 2010.

  1. LongbowFoSho macrumors member

    Joined:
    Nov 26, 2010
    #1
    Customer wanted me to JB & UL their new bootrom 3GS on 4.2.1, so I warned them about the possibility of losing GPS, the iPad baseband itself, being stuck with custom firmware forevar, etc.

    They said they didn't care.

    So, I said OK. Luckily it still had SHSH for 4.1, so I was at least able to downgrade it to 4.1 before doing the JB & UL.

    But, here's the problem: No Service with their T-Mobile sim card. Works great with a legit AT&T card (even with Ultrasn0w installed).

    What I know:

    - Its not their sim card. I put it in another JB & UL 3GS on 4.1 and it finds T-Mobile just fine.

    - The phone has water damage, or did at one time. Both the headphone and charging port indicators are pink, and the indicators on the logic board are orange.

    So, would updating it to 4.2.1 do any good? Is there any way to do that with this iPad baseband nonsense? I tried once using a custom 4.2.1 IPSW and another time using stock 4.2.1, and it failed both times. Actually, it gave me a 1015 error once (which made me think it worked) and a 1604 error the next time, but never actually updated to 4.2.1. I had to restore to a stock 4.1 IPSW through TU to get it out of Recovery Mode.

    CLIFFS:

    - No Service with T-Mobile sim card only.
    - Would update to 4.2.1 possibly fix it?
    - How to get to 4.2.1 since it has the iPad baseband?


    Thanks, guyzzz
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    On 4.1 you still need to upgrade to the iPad baseband.
     
  3. LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #3
    I know this is old, but it DID have the iPad baseband. Perhaps I didnt make that clear. Thats what was so puzzling about it. It simply refused to connect to T-Mobile's network.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You turned 3G off in the settings right?
    If you installed the ipad BB 06.15 and installed ultrasnow then it should unlock it.
     

Share This Page