No service...freeze...

Discussion in 'Jailbreaks and iOS Hacks' started by spotsphill, Apr 10, 2010.

  1. spotsphill macrumors regular

    Joined:
    Sep 26, 2009
    #1
    JB 3GS 3.1.2

    Yesterday I was loading a video from NBC.com and all of a sudden I got the "No service" indicator in the top left. I waited a few minutes for it to find some 3G coverage, only to realize my phone was frozen. I restarted the phone using the home/power button method and when it came back, it hung on the Apple logo for a good 30-40 minutes before finally booting up normally. I thought this might've been a fluke, but then last night I booted up (after I accidentally let my phone run down to zero battery) and the same 30-40 minute Apple logo thing happened. This morning I was browsing Safari again and all of a sudden "No service," freeze, restart, Apple logo, 30-40 minutes...

    The only thing that I've done recently is install a few updated versions of apps that I already had. Does this problem seem like an app conflict of some sort? If so, should I just go in and uninstall the apps that I just recently installed?

    I guess I wouldn't mind re-JBing if I had to, but wouldn't that mean that I would be forced to go to 3.1.3 which has a more limited JB (no tethering - I confess that I haven't read much about 3.1.3 JB because I wasn't planning on doing it for a while)?

    Sorry for the long post. Please help. Thanks.

    EDIT: It seems as though the Apple logo flashes every 10 minutes or so (as if it's being restarted)
     
  2. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #2
    Well, I took the plunge and I think I did a stupid thing...

    I went ahead and restored my JB 3.1.2 phone and it upgraded me to 3.1.3 (7E18) with firmware 05.12.01. I've read around a lot and everyone says that if I have a SHSH on file (which I do), I should be able to downgrade from 3.1.3 to 3.1.2 (thus allowing me to get back my untethered JB with internet tethering capabilities). I tried for a few hours but was unable to do so. In reading conflicting sources, it seems that I was unable to go back because I was upgraded to the new firmware.

    Can someone give me a definitive answer as to whether or not I will be able to do a untethered JB? If yes, what method? (no need to explain it here, just tell me where to look).

    Thanks!
     
  3. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #3
    I know this is a topic that people are tired of talking about, but could someone please help!? Having a 3GS without the JB is PAINFUL...
     
  4. Leet Apple macrumors 6502a

    Leet Apple

    Joined:
    Nov 10, 2009
    Location:
    Canada
    #4
    unless you need the unlock can't you just use Redsn0w and Jailbreak your 3Gs?
     
  5. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #5
  6. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #6
    Thanks mreddys. I had seen that post earlier today. I followed all of the steps on how to restore using SHSH (via iclarified) but when I got to the shift+restore, I didn't have an .ipsw file to use! I have the shsh file, but I don't have the .ipsw file. Where do I get that?

    I downloaded two .ipsw's (activated and not activated) and neither worked -- I got error 1600.

    I then tried just running blackra1n, but that didn't work either. I checked that my iBoot is the old version (got my phone in Sept. 2009) so I should be able to do an untethered JB.

    I'm running out of ideas!
     
  7. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #7
    You can download the firmware files from here: http://www.iclarified.com/entry/index.php?enid=750

    Your download file name will be iPhone2,1_3.1.2_7D11_Restore.ipsw. Please make sure that you read the part in BOLD

    The other 2 ipsw that you downloaded were custom? you cannot restore to a custom firmware until AFTER you are jailbroken. You need to follow those instructions to downgrade first, then use redsnow to jailbreak.
     
  8. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #8
    Great, thanks. I am downloading the correct ipsw now. How does iTunes know that I have the shsh? Nothing I'm doing to downgrade is pointing to the shsh file. I'm afraid I might be missing a step or something:

    1) I added 74.208.10.249 gs.apple.com to the end of etc/hosts
    2) in DFU, shift+restore and select the ipsw that I am currently downloading

    where is it telling itunes/iphone to look at my shsh?
     
  9. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #9
    IT WORKED with the correct ipsw!!! THANKS!

    The only problem is that after the 2nd 1015 error, i JBed with blackra1n and now i don't have any reception. How do I get AT&T to work!?
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Blackra1n does that sometimes. Redsn0w would have been my choice. Fewer problems.
     
  11. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #11
    Blackra1n has worked for me several times. What would y'all advise for me moving forward?
     
  12. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #12
    I keep on reading about iRecovery to get it out of the recovery loop, but I haven't been able to get it to work with Windows 7. I follow the directions and I keep on getting the Blue Screen of Death! Anyone have any success in getting:

    1) the phone out of the recovery loop
    2) JB?

    I feel like I'm so close! (successfully downgraded to 3.1.2 but just not activated!)
     
  13. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #13
    There was another post here earlier with similar issues, and he used redsnow to JB again after the 2nd error, but even his phone was not receiving any signal. I cant seem to figure out why. Even redsnow does not give the option of 'hacktivate or not'.

    http://forums.macrumors.com/showthread.php?t=891914
     
  14. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #14
    Neither blackra1n nor Redsn0w work! I think iRecovery might be necessary. Any advice!?
     

Share This Page