No service on unlocked 3g :-0

Discussion in 'Jailbreaks and iOS Hacks' started by kevindosi, Sep 2, 2009.

  1. kevindosi macrumors regular

    Joined:
    Mar 16, 2006
    #1
    I've been using an iPhone 3g on TMobile for a while now. One day I woke up and it said "No service." Later, I got a message that said something like "Can not make or receive calls. Restore in iTunes." So, I did that. No good. I tried erasing all the data and setting on my iPhone, then installing 3.0 on there fresh from Apple, then using redsn0w to jailbreak it and ultrasn0w to unlock it. Still, no service.
    This is an iPhone 3g using version 3.0 (7A341) firmware 04.26.08.
    I'm moving to France in a few weeks where I suspect I'll be able to use it with any carrier anyway, but I'd really like to get this fixed as soon as possible. Can anyone help me, please and thanks? I would be forever in debt to you.
     
  2. CBR900RR macrumors 6502a

    Joined:
    Oct 11, 2008
    Location:
    Middle of Pacific
  3. kevindosi thread starter macrumors regular

    Joined:
    Mar 16, 2006
    #3
    Yes, I've done that. Does it matter that I'm using Snow Leopard and the latest version of iTunes?
     
  4. kevindosi thread starter macrumors regular

    Joined:
    Mar 16, 2006
    #4
    OK, I've just spent almost the entire day trying different combinations of installing 3.0.1, jailbreaking with redsn0w and unlocking with ultrasn0w. I'd be happy to pay anyone who can help me fix this "no service" problem. Anyone?
     
  5. kevindosi thread starter macrumors regular

    Joined:
    Mar 16, 2006
    #5
    There's got to be some iPhone guru out there who can help me with this. I'm leaving for a trip in 2 weeks so I really want to get this fixed asap. Can anyone help me, please? I could send a paypal gift of appreciation your way.
     

Share This Page