'no service' & 'searching' did you fix it or return it?

Discussion in 'iPhone' started by Sir Ruben, Nov 30, 2011.

  1. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #1
    I am specifically talking about the scenario whereby the phone will go to no service or searching and not recover unless you reboot the phone.

    A family members phone started doing this so I restored the phone and it worked fine for 2 weeks. Now its started again and a restore didnt resolve this time.

    Im running out of ideas and wondering if this is a hardware fault. Im close to having to send it off to Apple out of warranty :(

    If the worst comes to the worst, im in the UK, how much would Apple charge to take the faulty iPhone and give me a replacement?

    Cheers
     
  2. Bernard SG macrumors 65816

    Bernard SG

    Joined:
    Jul 3, 2010
    #2
    Did you try to Reset Networks Settings ?
    Hopefully it's not defective hardware.
     
  3. jg2693 macrumors newbie

    Joined:
    May 25, 2011
    Location:
    Torrance, CA
    #3
    Omg mine does the EXACT same thing. When I come up from the subway, my phone won't find service again until I reboot the phone. It's so odd.
     
  4. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #4
    I think a lot of people just tolerate it, but as far as Im concerned if a phone loses a signal and cant pick it up again without a reboot then its a pretty useless phone dont you agree.
     
  5. Sir Ruben, Dec 9, 2011
    Last edited: Dec 9, 2011

    Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #5
    Okay well I believe I have tried everything and nothing is resolving the problem. here are the symptoms and what I have tried to resolve the issue:

    Symptoms:

    * Phone will go to 'No Service' or 'Searching' and will not regain a signal unless phone is rebooted at which point it will regain full signal

    * When the phone shows 'No Service' putting it in/out of flight mode results in the signal bars returning but no carrier name and still wont work

    Tried:

    * Replacement Orange sim (in case it was a faulty sim card)

    * Different Orange sim (with different tel no)

    * Turned off 3G

    * Turned off cellular data

    * Reset network settings

    * Settings > Carrier > switched 'Automatic' to off and selected carrier manually

    * Erase all content & settings (then restored from iCloud backup)

    * Restored phone in DFU mode and downloaded fresh copy of iOS5.0.1 from the internet (then restored from iCloud backup)

    * Out of warranty replacement iPhone 4 via Apple Store (£119)

    My next step is to try and claim my £119 back from apple as the genius told me I needed a replacement, however the exact same issue still persists.

    A google search finds tons of forums with people having the exact same problem, but after hours and hours of trawling forums I am yet to find a solution, all I find are people like me who are desperate to get it sorted.

    At this point if anyone can add anything to help other than ditching it and buying an Android handset then please do.
     

Share This Page