"NO SERVICE" -> tried everything! NEED HELP!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iAndroid, Mar 23, 2011.

  1. iAndroid macrumors newbie

    Joined:
    Mar 23, 2011
    #1
    Hi all,

    I purchased a used iPhone 3G. Before buying, I tried my sim card on it and it worked. But now it does not work at all! It searches and then says no service. I have tried everything! Spent countless hours trying, no luck.

    Specs:

    iPhone 3G 16GB
    BB: 6.15
    Running: 4.1
    Bootloader: 6.02
    He had it jailbroken and unlocked before.
    I believe it is originally a Fido iPhone (put in Fido sim to activate)
    I use redsn0w.

    At first, it was only my Fido sim card that did not work, my friends Fido sim had worked. I decided to restore it and re-jailbreak and unlock. After having does this, no sim cards work at all. All say "no service".

    I have searched and read almost all post and researched many times to find a fix but no luck. I have very close to throwing this POS against a bricknwall...

    I have tried almost everything! Such as:

    - Restoring
    - Restoring and jailbreaking and unlocking
    - Turning on and off
    - Turning 3G on and off and rebooting
    - Playing around with flight mode
    - Almost every other method...


    Could it be a hardware or antenna problem?

    Thank you all for reading.
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
  3. iAndroid thread starter macrumors newbie

    Joined:
    Mar 23, 2011
    #3
    Yes, I un-installed and re-installed plenty of times.
    Ultrasn0w should not even matter as I think I am using the original.
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
  5. iAndroid, Mar 23, 2011
    Last edited by a moderator: Apr 11, 2011

    iAndroid thread starter macrumors newbie

    Joined:
    Mar 23, 2011
    #5
    Yes. I tried everything.
    I should just cut my losses and sell it as is.. or maybe I'll go pay for a professional to help mee... VERY frustrated.

    So... I totally restored the iPhone. Popped in original sim card and now I'm getting "waiting for activation this may take some time."

    Anyone have that before?
    Or does it look like antenna problems?
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    The original sim that you popped in is a working sim or an old inactive simcard?
    Also what firmware are you on right now and are you jailbroken?
     

Share This Page