Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

TillysWily

macrumors regular
Original poster
Jun 8, 2011
213
16
So when my phone sets on wifi all night at home then I leave the house for work in the morning my iphone XS will not connect to LTE. I have to turn it off then back on to get it to pick up a town. I have only noticed since the last update. Has anyone else had this issue?
 

Banglazed

macrumors demi-god
Apr 17, 2017
4,474
7,324
Cupertino, CA
This happens throughout iOS 12 testing. After a night with only WiFi, toggle off airplane mode will get 1 bar and slowly recover signal or no service. If I toggle off airplane outside, it would instantly recover the signal. I've learned to just leave cellular on since the house has excellent coverage from the signal booster.

Try to toggle on airplane mode and off instead of turning off the device might be easier.
 

ET iPhone Home

macrumors 68040
Oct 5, 2011
3,823
529
Orange County, California USA
So when my phone sets on wifi all night at home then I leave the house for work in the morning my iphone XS will not connect to LTE. I have to turn it off then back on to get it to pick up a town. I have only noticed since the last update. Has anyone else had this issue?
I do on my XS Max. It never connects to LTE. I have to toggle OFF and Toggle to LTE.
 

mikethebigo

macrumors 68020
May 25, 2009
2,204
906
YES thank you that I’m not crazy!

I’ve been tooling with this all day, triggering WiFi on and off at different times to see if cell data was lost.

I’ve noticed that the bug sometimes happens after the phone swaps over to WiFi calling. Like right after that, I turn off WiFi, and bam data is gone. I’m stuck at 1-2 bars, then quick airplane mode and suddenly I’m back to 3 bars with data.

This is on VZW. I’m really honestly wondering if the combo of the enabled eSIM, normal SIM, and WiFi calling is ****ing something up. Like the phone doesn’t know it’s supposed to swap back to the tower, I dunno. Could also be unrelated.
 
Last edited:

AppleB

macrumors 65816
Oct 18, 2011
1,133
1,343
I’m not experiencing this issue on a Max with 12.1

After updating to 12.1 I checked for a carrier update and one was available. I’m on Sprint.
 

Funsize93

macrumors regular
May 23, 2018
111
64
Australia
If you want Apple to know about your issue and fix it as soon as possible, it would be best to contact Apple support so that they can gather logs and forward them to Apple Engineers. This helps Apple identify trends and issues so that they can action them as soon as possible. You contacting Apple helps the greater community, it helps Apple improve their products.
 
  • Like
Reactions: crouch

NorthSeaBeach

macrumors 6502
Oct 29, 2014
322
217
The Hague
I experienced it today. No cell/4G connection at all on my Xr. Toggling airplane mode didn't do a thing. I had to turn the phone off and on again to get a connection:(.
 

jona2125

macrumors 6502a
Jul 12, 2010
780
651
I experienced it today. No cell/4G connection at all on my Xr. Toggling airplane mode didn't do a thing. I had to turn the phone off and on again to get a connection:(.

Please god no. My XR has been good to me so far I really hope it's not another affected device.
 

TillysWily

macrumors regular
Original poster
Jun 8, 2011
213
16
I'm on T-Mobile and have never had this issue till the 12.1 update. Toggling airplane mode or wifi never works. The bad thing for me is it will say I have 1 or 2 bars but when you open anything that needs data it says "no internet connection". So it's definitely something with the phone software. Have to cut it off and back on every morning I leave the house.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.