No signal from external mic on Garageband.

Discussion in 'Digital Audio' started by CLF, May 26, 2010.

  1. CLF macrumors newbie

    Joined:
    May 26, 2010
    #1
    I'm a newbie to Garageband and I'm trying to record a vocal track using my external mic. The mic (a Shure BG 3.1) is plugged into my Audiobox USB box, which is connected to my MacBook Pro, but GB isn't registering any signal from the mic. I can hear my voice coming through the mic into my headphones, but there's nothing coming through on Garageband. And the Audiobox worked fine recording midi. Can anyone help? Is it my weird mic? Or is there something really simple I'm missing?
     
  2. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #2
    This is probably the device's own hardware monitoring. Make sure you have the correct input in GB's audio/midi preferences and the right input to record from in the track info.
     
  3. CLF thread starter macrumors newbie

    Joined:
    May 26, 2010
    #3
    Still stumped

    I've checked the input/output settings and they're all correct (input and output - Audiobox USB). I've changed my Mac's sound settings to be input and output Audiobox USB, and I've had a damn good look through every other setting or level control I can find, but still no level is registering on GB from my external mic. I've also tried switching instrument inputs on the Audiobox just in case. I've noticed that in the track info pane (where you pick Mono/Stereo etc) the recording level is at at the lowest but won't allow me to move it? Does this mean anything? Can anyone shed any light on this problem? I can't work out what I'm doing wrong.
     

Share This Page