No Signal / Service with Iphone IOS5

Discussion in 'iOS 5 and earlier' started by yyyames, Nov 29, 2011.

  1. yyyames macrumors newbie

    Joined:
    Nov 29, 2011
    #1
    My phone has been having some serious signal issues lately. I never have a signal anymore and when It does come back it is only for a short while. Almost all my calls are dropped or fail. I contacted AT&T as I thought it was a signal issue but I am beginning to think it is my phone. I restored the phone and still no service. Can anyone offer some advice or a fix? Pretty bummed.
     
  2. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #2
    Yikes. When you restored did you restore as new and not JB? Which iPhone is it? It sounds like a Genius appointment is in your near future...
     
  3. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #3
    Your sim card could be faulty. Try a replacement.
     
  4. yyyames thread starter macrumors newbie

    Joined:
    Nov 29, 2011
    #4
    At AT&T I replaced the SIM card, to be fair they have been pretty helpful over the phone. In store they were pretty rude but whatever. Im still getting poor reception and today over the phone a rep said they were "adding" 3G to a tower by me so that could be the cause? Seems a bit late to be adding 3G lol.
     
  5. reinhard macrumors newbie

    Joined:
    Oct 19, 2011
    #5
    Sim pin

    Had a similar problem when I got my iPhone 4S (O2 Ireland). Problem was the SIM PIN. O2 advised to disable the SIM PIN, which helped. see also http://community.o2online.ie/t5/Apple/bd-p/14

    Not sure if that's specific to O2 Ireland or generic iPhone 4S issue.

    Reinhard
     

Share This Page