No SIM card installed (iPhone 4)

Discussion in 'Jailbreaks and iOS Hacks' started by paparazzzo, Aug 30, 2011.

  1. paparazzzo macrumors newbie

    Joined:
    Aug 30, 2011
    #1
    Dear all, here is my story. Please be so kind to read it all. Note that I am willing to pay in order to fix my iPhone.

    I purchased locked Fido iPhone in Canada and took it to Europe. It was iPhone 4, 04.10.01, baseband 04.10.01. I jailbroken it with jailbreakme.com and unlocked with gevey sim card. It worked for one day only. It simply froze. I tried to reboot it and it stucked on apple logo. I tried then to restore it to original 04.10.01 firmware, but could not do it due to problem with hosts file. Spent 2 days trying to figure out how to restore it, but it simply wouldn't let me do that. I removed gs.apple.com line from my mac hosts file, but it didn't help.

    Finally, I gave up and did something very stupid. The only other option I had was to upgrade it to 4.3.5 firmware, and i did it. Now when I start my iPhone I get "No SIM card installed. Insert a valid sim with no PIN lock to activate iPhone".

    I can't pass that screen. I tried to enter 4 different SIM cards, and it didn't help. I entered my SIM card to other phone, removed the SIM PIN number, but it still didn't help.

    Could somebody be so kind to help me out, please, please, please. Once again, I am ready to pay in order to fix my iPhone.

    NOTE: I have Fido SIM card (prepaid), and tried to use that SIM, but it didn't help.
     

    Attached Files:

    • sim1.jpg
      sim1.jpg
      File size:
      26.6 KB
      Views:
      672
  2. paparazzzo thread starter macrumors newbie

    Joined:
    Aug 30, 2011

Share This Page