Phones "No Sim Card - Roaming Indicator Off" On 2013 Sprint Moto X

Dj64Mk7

macrumors 65816
Original poster
Sep 15, 2013
1,161
322
Just yesterday, I installed CyanogenMod 12.1 onto my 2013 Sprint Moto X (ghost) using ADB and TWRP (I'm not rooted.) Everything was working just fine until about an hour ago. I noticed a strange message on the lock screen, which says "No SIM card - Roaming Indicator Off". I have verified multiple times that there is indeed a SIM card in the tray, and I can make and receive calls/texts just fine, even cellular data works just fine. What does this message mean? Should I be concerned about it? Will it affect my phone negatively?
 

three

macrumors 65816
Jan 22, 2008
1,068
192
Washington State
From my quick look on XDA, it looks to be a common issue for Sprint Moto X devices. If data / calling / texts work, I wouldn't worry about it. Keep a eye on the changelogs with future updates and update when they're available.
 

Dj64Mk7

macrumors 65816
Original poster
Sep 15, 2013
1,161
322
From my quick look on XDA, it looks to be a common issue for Sprint Moto X devices. If data / calling / texts work, I wouldn't worry about it. Keep a eye on the changelogs with future updates and update when they're available.
Since a few hours ago, data has stopped working. All I get is the cell signal triangle with an exclamation point next to it. Every app says that I'm offline, and nothing resolves this issue.
 

mi7chy

macrumors 603
Oct 24, 2014
5,954
6,919
I know one of the quirks from trying CM is you have to reselect your APN otherwise you might have no mobile data.