"No SIM" message - Iphone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jgl51, Aug 30, 2010.

  1. jgl51 macrumors newbie

    Joined:
    Aug 13, 2010
    #1
    I just got my Iphone 4 and cut my SIM card using a template from the web into a micro SIM. I inserted the SIM and powered ON the phone. I got the message "Insert a SIM"!! I re-tried several time... nothing.
    Then I tried the SIM card in my old phone using an adapter and got the message Insert a SIM too! Really confused. Note that the adapter is a bit flimsy and am not sure I have good contact in the old phone.

    I also tried reset (hold power button several seconds) without success!
    The SIM card is prepaid from DIGI Malaysia.

    Can anyone help?

    Thanks
     
  2. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #2
    You might have just borked the SIM and it no longer works. This happened to me the first time I tried cutting down a SIM card to micro SIM size (an old SIM I cut up first for practice before using an active SIM). You may need to just go get a replacement and try again.
     
  3. jgl51 thread starter macrumors newbie

    Joined:
    Aug 13, 2010
    #3

    I am afraid of this. But how could I destroy the card if I follow the template (microsim.com)? I only cut into the plastic not the copper contacts...

    Any idea so I do not destroy the next one?

    What do hold from these "punchers" to punch the micro-SIM out of a nromal one?
     
  4. chai2030 macrumors newbie

    Joined:
    Sep 28, 2010
    #4
    Hi, had u solve the problem? i get the same problem as well, the sim card not regonize in Iphone 4 but when i put on sim adapter it still can use on others phone, don't know what happen!!

    pls help.. thanks!
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Maybe its not sitting perfect or your cutting was slightly off.
     

Share This Page