no sim

Discussion in 'iPhone' started by pearlbrian, Jul 4, 2010.

  1. pearlbrian macrumors member

    Joined:
    Feb 20, 2009
    #1
    So my iphone 4 seems to be having a problem with its sim card. It constantly hits me with the "no sim" message, and i have to reboot it for it to recognize it again. Never saw anything like this on my 3g. Think its defective?
     
  2. Alonzo84 macrumors 6502a

    Alonzo84

    Joined:
    Dec 18, 2009
    Location:
    North Carolina
    #2
    Others have mentioned this as well. Try taking out the SIM and reinserting it. Seems to have resolved the issue for some.
     
  3. shadrap macrumors 6502

    Joined:
    Jul 6, 2009
    Location:
    Mayberry
    #3
    Resolved my issue also.
     
  4. pearlbrian thread starter macrumors member

    Joined:
    Feb 20, 2009
    #4
    Not mine. Tried everything. Gonna take it in i guess. Not impressed so far.
     
  5. nygfan80 macrumors regular

    Joined:
    Apr 13, 2010
    Location:
    PA
    #5
    Same problem, went to the apple store, the genius also saw the issue and swiped it out for me.
     
  6. hammster1 macrumors newbie

    Joined:
    Jul 1, 2010
    #6
    Yup, had the same problem with my iPhone 4, about 1 day after getting it.

    Reset Sim card - didn't fix it
    Got new Sim card from AT&T store - didn't fix it
    Apple "Genius" reviewed problem, did restore, saw it was hardware problem, replaced phone

    Now I'm waiting to see if replacement phone exhibits same problem. It's only been 1 day, so I'm cautiously optimistic.

    "Genius" said he has seen a couple with the same hardware issue. Said it is due to sim contact problem within phone.

    Still, not a good start for this new iPhone customer, who already waited a week for mine to come in via "priority list" - but, I'll cut them some slack due to the large quantity getting sent out (there will always be a few bad ones, and the new customers likely end up with the bad ones, right?)
     
  7. spblat macrumors 6502a

    spblat

    Joined:
    Jun 18, 2010
    #7
    Been there. Tried new SIM and new OS. Nothing helped. Bad phone hardware. Have them swap it for you. I've been good for several days.
     

Share This Page