No sleep for iMac 2011

Discussion in 'OS X Mavericks (10.9)' started by Imac Sam, Mar 8, 2014.

  1. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #1
    I finally upgraded to Mavericks when 10.9.2 was released, on my Mid-2011 27" Imac. All has been working well except that the computer will not go to sleep. The screen saver will activate and the display will sleep but the computer itself still remains awake. I can force it to sleep from the apple menu, but it will not do it by itself. Yes I have checked my energy saver settings in system preferences, and all is good there. It would go to sleep fine in Mountain Lion, but never in Lion(again for some odd reason). Nothing in my configuration of the machine has changed other than the Maverick upgrade.

    Any ideas?
     
  2. nout72 macrumors regular

    nout72

    Joined:
    Dec 27, 2007
    Location:
    The Netherlands
    #2
    Do you by any chance have Western Digital software installed?
    WD Smartware and the likes?
    I had and my Mac didn't want to go to sleep as well.
     
  3. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
  4. Imac Sam thread starter macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #4
    Okay here is what I got. I see that have "External Media" as a 1, and that is my Time Machine Drive and an "Extra Archives" drive. (determined after I shut off my external drives to find the culprit) They are firewire 800 drives. I also have one Thunderbolt drive as a clone of my machine in worst case. But it is rarely on. But when it is on, it also sets thes ExternalMedia to on


    Assertion status system-wide:
    BackgroundTask 0
    PreventDiskIdle 0
    ApplePushServiceTask 0
    UserIsActive 0
    PreventUserIdleDisplaySleep 0
    InteractivePushServiceTask 0
    PreventSystemSleep 0
    ExternalMedia 1
    PreventUserIdleSystemSleep 0
    NetworkClientActive 0
    Listed by owning process:
    pid 18(powerd): [0x000000090000012c] 01:02:12 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
    Kernel Assertions: 0x24=USB,THNDR
    id=500 level=255 0x4=USB mod=3/9/14, 7:40 AM description=EHC2 owner=AppleUSBEHCI
    id=501 level=255 0x20=THNDR mod=3/9/14, 8:09 AM description=NHI0 owner=AppleThunderboltHAL
    id=502 level=255 0x4=USB mod=3/9/14, 7:42 AM description=EHC1 owner=AppleUSBEHCI
     
  5. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #5
    Exact same problem here. 2011 iMac, no sleep after 10.9.2 update. No external media here though. 10.9.2 did fix sleep on my 2011 Mac Mini, so now I just need to get this going again. Damn, Mavericks has just been a mess... >_<

     
  6. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #6
    ExternalMedia is usually not the problem. I would try disconnecting USB/other peripherals. (I have a 2012 mini & 2013 imac, both sleep with ExternalMedia running)
     
  7. Imac Sam thread starter macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #7
    I tried that, and restarted the machine and launched no programs, waited the 1 hour(my setting) for my sleep to kick in and it never did. I feel it's an issue with 10.9.2 and the Firewire Drives, which I am going to disconnect and try my test on the computer again.
     
  8. -Tobi- macrumors newbie

    Joined:
    Feb 7, 2012
    Location:
    Hanover, Germany
    #8
    Is "Wake for Wi-Fi network access" option turned on?
    You can find it in system preferences > energy saver > tab power adapter.
    If it's turned on, turn it off and check again if your iMac stays awake.
     
  9. Imac Sam thread starter macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #9
    No I only have tabs for Power and UPS, as I use wired ethernet directly to my router for network access.

    ....... So as for me latest test, I left all external drives off restarted the computer and ran no programs and once again it never fell asleep.
     

    Attached Files:

Share This Page