No sleep settings for Mac mini

cosrocket

macrumors regular
Original poster
Jul 7, 2008
132
7
I just received a Mac mini today, set it up and I'm having a strange problem. When I put it to sleep after about a munute it comes back to life, then goes to sleep again, comes back to life and continues that pattern. I went into System Preferences clicked on Energy Saver and noticed there is no slider to set a time for the Mac mini to go to sleep, there is only a slider to turn the display off after a certain time. What could have happened to the slider to put the Mac to sleep?
 

chscag

macrumors 68040
Feb 17, 2008
3,236
1,006
Fort Worth, Texas
Several things you can do: First, try a SMC reset as that controls the sleep function. Also check your Activity Monitor to see if you have anything running in the background that can wake the Mini.

And by the way, assuming you're running Mojave... there is no longer a sleep setting in System Preferences, Energy Saver, so you need not be concerned about it being missing.
 

cosrocket

macrumors regular
Original poster
Jul 7, 2008
132
7
Several things you can do: First, try a SMC reset as that controls the sleep function. Also check your Activity Monitor to see if you have anything running in the background that can wake the Mini.

And by the way, assuming you're running Mojave... there is no longer a sleep setting in System Preferences, Energy Saver, so you need not be concerned about it being missing.
Thanks, I'll try that. I didn't know that setting was removed in Mojave.
[doublepost=1550028912][/doublepost]
Are you wearing an Apple Watch?
Nope, I'm not.
[doublepost=1550029167][/doublepost]Tried the reset, didn't work. This is happening with both HDMI connection and Display port to Thunderbolt 3 port, doesn't matter which port on the Mac mini. Very annoying. Question, when the Mac mini is asleep is the little light on the mini supposed to change color, pulse or just stay lit? Because it always stays lit white.
 
Last edited:

chscag

macrumors 68040
Feb 17, 2008
3,236
1,006
Fort Worth, Texas
I can't answer your question about the light on the Mini, but I wonder if your monitor connection or your monitor is the reason the Mini will not stay asleep? Do you by chance have another monitor that you can try?
 

Ruskes

macrumors regular
Jan 4, 2019
135
37
Try following in Terminal (in Utility folder)
to see what is waking it up

pmset -g assertions
 

madmin

macrumors regular
Jun 14, 2012
153
115
I went into System Preferences clicked on Energy Saver and noticed there is no slider to set a time for the Mac mini to go to sleep, there is only a slider to turn the display off after a certain time. What could have happened to the slider to put the Mac to sleep?
Not sure what happened here but I have seen similar problems with System Preferences in Mojave. For example, I had a problem with the option to 'require an administrator password to access system wide preferences' not working. The solution was to delete or move the authorization file (e.g: /var/db/auth.db to /var/db/auth.db.old) and reboot. The securityd process creates a new default version of this file on reboot if it doesn't find an existing one. That may or may not fix your issue, but I'd be tempted to try it, if I were you. If it doesn't fix anything, you can always put the old version back and reboot to return to your previous state.

EDIT: D'oh, sorry I just remembered the sleep setting's gone in Mojave. I may as well leave this here anyway, in case it's useful to someone :)
 
Last edited:

cosrocket

macrumors regular
Original poster
Jul 7, 2008
132
7
Thanks, this is what I'm getting:

Last login: Wed Feb 13 08:22:57 on console

Jareds-Mac-mini:~ jared$ pmset -g assertions

2019-02-13 08:24:16 -0500

Assertion status system-wide:

BackgroundTask 0

ApplePushServiceTask 0

UserIsActive 1

PreventUserIdleDisplaySleep 0

PreventSystemSleep 0

ExternalMedia 0

PreventUserIdleSystemSleep 0

NetworkClientActive 0

Listed by owning process:

pid 95(hidd): [0x000000100009807d] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968878.3"

Timeout will fire in 180 secs Action=TimeoutActionRelease

Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE

id=504 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14600000 owner=USB Receiver

id=505 level=255 0x100=MAGICWAKE mod=12/31/69, 7:00 PM description=en1 owner=en1

id=506 level=255 0x8=BT-HID mod=12/31/69, 7:00 PM description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

Idle sleep preventers: IODisplayWrangler

Jareds-Mac-mini:~ jared$
 
Last edited:

Fishrrman

macrumors P6
Feb 20, 2009
17,384
5,622
My opinion only follows.

There's no need to "sleep" a 2018 Mini.
Just "put the display to sleep", and don't bother with the rest of it.

Consider:
When the Mini "sleeps", the power supply is going to be on, anyway. That means electrons are still flowing through it.
When the Mini "sleeps", the SSD isn't going to use much (any?) power.
When the Mini "sleeps", how much more power will the RAM use? Doesn't RAM have to be minimally refreshed and "kept alive" when sleeping, anyway?

I have computer sleep set to "Never" on my 2012 Mini.
I have "display sleep" set to 15 minutes.

But if I walk away from the Mini, and I know I'm going to be gone for more than 15 minutes, I just "reach forward" and TURN OFF the display with the off/on switch. That probably saves more power right there.

But... "sleep" on the 2018 Mini... is pretty much an oxymoron.
If you think you're "saving energy" by "sleeping" the Mini, perhaps you ought to think again!
 
  • Like
Reactions: mikehalloran

Ruskes

macrumors regular
Jan 4, 2019
135
37
Thanks, this is what I'm getting:

Last login: Wed Feb 13 08:22:57 on console

Jareds-Mac-mini:~ jared$ pmset -g assertions

2019-02-13 08:24:16 -0500

Assertion status system-wide:

BackgroundTask 0

ApplePushServiceTask 0

UserIsActive 1

PreventUserIdleDisplaySleep 0

PreventSystemSleep 0

ExternalMedia 0

PreventUserIdleSystemSleep 0

NetworkClientActive 0

Listed by owning process:

pid 95(hidd): [0x000000100009807d] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968878.3"

Timeout will fire in 180 secs Action=TimeoutActionRelease

Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE

id=504 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14600000 owner=USB Receiver

id=505 level=255 0x100=MAGICWAKE mod=12/31/69, 7:00 PM description=en1 owner=en1

id=506 level=255 0x8=BT-HID mod=12/31/69, 7:00 PM description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard

Idle sleep preventers: IODisplayWrangler

Jareds-Mac-mini:~ jared$
*******************************************************
Hi
Thanks for running the pmset g assertion in Terminal.
As you can see it says it is the MAGICWAKE keeping your Mac from sleeping.

How to fix it ?

You Bluetooth track pad wakes up (do you have a Cat?) other BT devices interference, low battery... see this for more.

To test do "Allow Bluetooth devices to wake this computer" OFF.

If you have the Magicwake app installed, remove it.
 

cosrocket

macrumors regular
Original poster
Jul 7, 2008
132
7
This problem gets stranger. I turned off the monitor since I couldn’t put the Mac mini to sleep and when I came back to turn the monitor on it would not power on. I pushed the power button several times, pulled the plug and plugged it into another outlet and it still wouldn’t power on. Just when I thought the monitor was dead, I pulled the Display port to Thunderbolt 3 cable out from the monitor and it powered on. Then I decided to go back and try the HDMI cable again and the display blinked and colors flashed, there were all these artifacts and then it went from a normal screen to snow, it was CRAZY. (I used multiple HDMI cables including a 2.0 cable I just received).

Later I borrowed a friend’s monitor that only has an HDMI port and it acted on his monitor exactly like it did on mine using the HDMI port. So I packed up the Mac mini figuring its defective and brought it to an Apple Store and got a new one. I hooked the new Mac mini up and to my surprise and frustration it has exactly the same problem as the first one with both monitors.

I am stumped. I can’t believe I got 2 defective Mac minis. I know the monitor does work because I had a Macbook Pro used in clamshell mode using an HDMI cable with an HDMI to mini display port adapter and my friends monitor works with his computer. If anyone can think of what else could be causing this I would really like to know what it could be.
 

ncrypt

macrumors 6502
May 16, 2012
314
190
UK
turned off the monitor since I couldn’t put the Mac mini to sleep and when I came back to turn the monitor on it would not power on.
I have the same issue with my mini, so now I never turn the monitor off, only let it sleep.
 

SuperMatt

macrumors 6502a
Mar 28, 2002
678
273
I understand people don't normally need to worry about a system going to sleep, but I want the computer to stay active so I can connect to it remotely with TeamViewer. On the iMac I'm working with, there is only a setting for display sleep, which I do want enabled. The system appears to be going to sleep because when I try to login remotely, I cannot unless somebody in the office goes to the machine and wakes it.
 

Boyd01

Moderator
Staff member
Feb 21, 2012
4,204
1,876
New Jersey Pine Barrens
On the iMac I'm working with, there is only a setting for display sleep, which I do want enabled.
You posted this to the Mac Mini forum, maybe you can find more help in the iMac forum? But according to this, on the iMac you should have an option in the Energy Saver preference pane, "Prevent computer from sleeping automatically when the display is off"

https://support.apple.com/en-us/HT202824

And according to that article, there should be a slider for computer sleep on the Mini. Is this different under Mojave?
 

Ruskes

macrumors regular
Jan 4, 2019
135
37
I understand people don't normally need to worry about a system going to sleep, but I want the computer to stay active so I can connect to it remotely with TeamViewer. On the iMac I'm working with, there is only a setting for display sleep, which I do want enabled. The system appears to be going to sleep because when I try to login remotely, I cannot unless somebody in the office goes to the machine and wakes it.
>> here you go
https://computers.tutsplus.com/tutorials/quick-tip-how-to-stop-your-mac-from-sleeping-using-the-command-line--mac-50905

or this
https://apple.stackexchange.com/questions/8143/how-can-i-wake-up-my-mac-from-sleep-mode-remotely
 

SuperMatt

macrumors 6502a
Mar 28, 2002
678
273
You posted this to the Mac Mini forum, maybe you can find more help in the iMac forum? But according to this, on the iMac you should have an option in the Energy Saver preference pane, "Prevent computer from sleeping automatically when the display is off"

https://support.apple.com/en-us/HT202824

And according to that article, there should be a slider for computer sleep on the Mini. Is this different under Mojave?
You're doubly right! I posted to the wrong forum, and there was in fact a checkbox for preventing computer sleep. Thanks, and now back to our regularly scheduled Mac mini programming!
 
  • Like
Reactions: Boyd01

adamk77

macrumors 6502a
Jan 6, 2008
510
149
My opinion only follows.

There's no need to "sleep" a 2018 Mini.
Just "put the display to sleep", and don't bother with the rest of it.

Consider:
When the Mini "sleeps", the power supply is going to be on, anyway. That means electrons are still flowing through it.
When the Mini "sleeps", the SSD isn't going to use much (any?) power.
When the Mini "sleeps", how much more power will the RAM use? Doesn't RAM have to be minimally refreshed and "kept alive" when sleeping, anyway?

I have computer sleep set to "Never" on my 2012 Mini.
I have "display sleep" set to 15 minutes.

But if I walk away from the Mini, and I know I'm going to be gone for more than 15 minutes, I just "reach forward" and TURN OFF the display with the off/on switch. That probably saves more power right there.

But... "sleep" on the 2018 Mini... is pretty much an oxymoron.
If you think you're "saving energy" by "sleeping" the Mini, perhaps you ought to think again!
What about the fan? I assume when it's in sleep mode, the fan's not spinning.

It may not use much energy, but the fan draws in air to cool the components which would mean more dust. I hate dust and am in constant battle with it. But maybe I'm being too OCD about it?
 

Fishrrman

macrumors P6
Feb 20, 2009
17,384
5,622
adamk77 wrote:
"It may not use much energy, but the fan draws in air to cool the components which would mean more dust. I hate dust and am in constant battle with it. But maybe I'm being too OCD about it?"

Yes.
You ARE being compulsive.

Please refer to this:
https://www.macintouch.com/community/index.php?threads/mac-mini-and-alternatives.1587/post-11127

At idle, the 2018 Mini uses about 7-8 watts.
At sleep, it uses around 5 watts.

That's a [giant ???] difference of.... 2-3 watts.

You're not going to save the environment with 2-3 watts per hour.

Even with the power OFF, the Mini is STILL consuming .5-.8 watts !!

Aside:
My Mini consumes NO watts when its powered off.
That's because I connect it to a power strip and TURN OFF power to the power strip when not running. NOT ONE of my peripherals consumes ANY power when powered off ...! ;)
 

adamk77

macrumors 6502a
Jan 6, 2008
510
149
adamk77 wrote:
"It may not use much energy, but the fan draws in air to cool the components which would mean more dust. I hate dust and am in constant battle with it. But maybe I'm being too OCD about it?"

Yes.
You ARE being compulsive.

Please refer to this:
https://www.macintouch.com/community/index.php?threads/mac-mini-and-alternatives.1587/post-11127

At idle, the 2018 Mini uses about 7-8 watts.
At sleep, it uses around 5 watts.

That's a [giant ???] difference of.... 2-3 watts.

You're not going to save the environment with 2-3 watts per hour.

Even with the power OFF, the Mini is STILL consuming .5-.8 watts !!

Aside:
My Mini consumes NO watts when its powered off.
That's because I connect it to a power strip and TURN OFF power to the power strip when not running. NOT ONE of my peripherals consumes ANY power when powered off ...! ;)

At the avg 12 cents/kw/hr in the States, that's only $3 per year if it's running 24/7 at 3 watts. I think I an afford that ;)

Thinking about this more, one caveat would be to be mindful of certain badly designed websites taking up a lot of CPU cycles. I think this is where sleep would be beneficial where you'd just let it sleep and not worry about it if you didn't want to hunt down the offending page.
 

dia3olik

macrumors member
Sep 14, 2007
83
18
Italy
hey guys, when I eject USB drives on my MM2018 the drives spindown after eject but then they spin up again (staying ejected from the OS tho), is it happening on yours too? thx!
 

Boyd01

Moderator
Staff member
Feb 21, 2012
4,204
1,876
New Jersey Pine Barrens
Trouble with sleeping the processor, is that it used to stop any downloads. That was annoying for a GB file at 5Mb/second.
You were lucky... for over ten years, the best internet connection available in my rural location was sub-megabit DSL (perhaps 800kb down/600kb up on a good day - which wasn't often). :D Have had 150/150 FIOS for the past two years, which is great.
 
  • Like
Reactions: Partron22