Other No SMS notifications on iPhone while using new MacBook Air

DDustiNN

macrumors 68000
Original poster
Jan 27, 2011
1,989
807
I got my new MacBook Air all set up, and everything is great. However, when signing into some sites, I use the two-factor authentication. The text gets sent, and I wait, wait, wait, check my Apple Watch, nothing there... unlock the phone, and sure enough, the text message is waiting right there for the past couple minutes. I just never got notified that it arrived. This seems to happen every time I'm actively using the MBA, and only for SMS. iMessages come straight through to the MBA.

SMS notifications work perfectly fine all other times. It's only when I'm on my laptop that they don't show up. I mean, the texts do show up, but I just don't get any sort of notification.

Also, this is exclusive to SMS messages. I still get all other notifications on my iPhone as normal, while using the MBA, such as Facebook Messenger and others.

So what am I missing? How do I get my iPhone to notify me of new messages while using the Mac?

Side note: I am guessing someone will suggest this, so I'll mention it. On my old MacBook Air, I had it set up to also receive SMS messages. That became annoying, as the notifications didn't seem to be shared between it and my phone. So whenever I'd open up the computer, I'd get a ton of dings for all the texts I received over the past days since I used it. Not my preferred solution. I just want my regular text notifications as normal.
 
Last edited:

akash.nu

macrumors 604
May 26, 2016
7,348
8,258
Traditional SMS will never work as iMessage because it essentially needs to go to your phone and then the phone forwards it to all the other devices. So that delayed ding is going to happen. Turn sms forwarding on and it will show up.
 

DDustiNN

macrumors 68000
Original poster
Jan 27, 2011
1,989
807
Traditional SMS will never work as iMessage because it essentially needs to go to your phone and then the phone forwards it to all the other devices. So that delayed ding is going to happen. Turn sms forwarding on and it will show up.
I think you’ve misunderstood my post. I’m not concerned about receiving SMS on my MacBook Air. I just want the notifications to work on my phone.

Currently, if I’m using my MacBook Air and I receive an SMS text, I receive no notification whatsoever. That makes no sense. I should at least be getting the notification to my phone, just like every other app does.
 

DDustiNN

macrumors 68000
Original poster
Jan 27, 2011
1,989
807
If you’re active on your MacBook it silences messages on the phone and vice versa.
That makes sense for iMessages. Those notifications appear on whichever device is currently active. But for SMS, those notifications are completely absent (anywhere) while using the computer, and the texts themselves never appear on the computer. They only appear on the phone. With no notification at all.
 

akash.nu

macrumors 604
May 26, 2016
7,348
8,258
That makes sense for iMessages. Those notifications appear on whichever device is currently active. But for SMS, those notifications are completely absent (anywhere) while using the computer, and the texts themselves never appear on the computer. They only appear on the phone. With no notification at all.
Did you try to logout of iCloud and log back in? Sounds like a sync issue.
 

Ebok

Suspended
Aug 22, 2018
460
655
That makes sense for iMessages. Those notifications appear on whichever device is currently active. But for SMS, those notifications are completely absent (anywhere) while using the computer, and the texts themselves never appear on the computer. They only appear on the phone. With no notification at all.
i think i understand what you're saying. seems to me that the way the system is setup it's muting the messages program itself and not individual types of messages (text vs iMessage), therefore when you're on your mac you receive your iMessage but since you have text message forwarding off then it completely mutes the messages app on either platform.

i'd recommend just turning on text message forwarding and getting your messages on your mac. don't know why you wouldn't want this in the first place.

settings > messages > text message forwarding
 

DDustiNN

macrumors 68000
Original poster
Jan 27, 2011
1,989
807
i think i understand what you're saying. seems to me that the way the system is setup it's muting the messages program itself and not individual types of messages (text vs iMessage), therefore when you're on your mac you receive your iMessage but since you have text message forwarding off then it completely mutes the messages app on either platform.

i'd recommend just turning on text message forwarding and getting your messages on your mac. don't know why you wouldn't want this in the first place.

settings > messages > text message forwarding
Because then, as I mentioned in the initial post, I get a dozen dings and notifications when opening up my computer, for all of the messages I’ve already seen on my iPhone.

I basically have to choose between annoying or more annoying.