No Sound (Disabled?) in 10.5

Discussion in 'macOS' started by jensepollense, Oct 31, 2007.

  1. jensepollense macrumors regular

    jensepollense

    Joined:
    Jan 13, 2007
    Location:
    Virginia Tech/Blacksburg, VA
    #1
    When I booted up my computer this morning, I realized that the volume icon in the menu bar was missing. I tried to adjust the volume with the keyboard, but an icon came up that makes it seem like it's locked. I went into System Preferences and under Sound, the computer doesn't seem to find the speakers for output or the internal microphone and line-in for input. Has anyone else had this problem? Anyone have any ideas of what could be wrong?

    Thanks
     
  2. Telp macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #2
    what is the icon that comes up that makes you think it is locked?take a picture of it and throw it up here. Try your MIDI setup or something. I think something like this happened to me about a year ago or something. I think it will be in you utilities folder.
     
  3. jensepollense thread starter macrumors regular

    jensepollense

    Joined:
    Jan 13, 2007
    Location:
    Virginia Tech/Blacksburg, VA
    #3
    I left my computer off for the day and when I came back to turn it on, it was all fine again. I don't know what happened but it's all good now.
    Thanks for your help nonetheless.
     
  4. kevo0822 macrumors regular

    Joined:
    Jul 13, 2007
    Location:
    New England
    #4
    For future reference for others who run into this problem, it happened on my friend's Macbook after she installed Leopard.

    On her Macbook, you could see a red light coming out of the "Audio Out" port on the side of the computer... it looked like the computer thought that an optical cable was plugged in for some reason. I just plugged some headphones into it, took them out and it was all good.
     
  5. maduarte macrumors newbie

    Joined:
    Jul 21, 2005
    #5
    It happened to me in a Powerbook 12 inch, 1.5GHz, 1.25GB RAM
    Here's the icon.
     

    Attached Files:

  6. 23am macrumors regular

    23am

    Joined:
    Oct 7, 2007
    Location:
    Stockholm, Sweden
    #6
    That occurs also when safe booting (holding shift during startup) the system. But I think it depends on that OSX doesn't start the sound drivers/something like that in safe boot.
    But this is a normal boot?
     
  7. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #7
    thats happened to me before. i think its OS X not loading the drivers properly. i simple log out/in fixes it. it could probably be compared to OS X loosing its exposé and dashboard key preferences and spaces not working at all. hopefully this is because its a .0 release and updates will fix it.
     
  8. jensepollense thread starter macrumors regular

    jensepollense

    Joined:
    Jan 13, 2007
    Location:
    Virginia Tech/Blacksburg, VA
    #8
    Yes, that's exactly what it looked like, and oddly enough, I have a 1.5 G4 Powerbook with 1.25 RAM too.
     
  9. whidbeyben macrumors member

    Joined:
    Nov 7, 2007
    Location:
    West Coast
    #9
    Looks like a 10.5 issue on PB G4 12" 1.5GHz

    I have run into the same issue with a PB G4 12" 1.5GHz running 10.5, the audio is disabled. System Pref Audio fails to detect internal sound input or output devices. When I rebooted using an external Firewire drive loaded with 10.4.11, the sound was back. I haven't tried a clean reinstall.
     
  10. Sirobin macrumors 6502

    Sirobin

    Joined:
    May 6, 2008
    Location:
    California
    #10
    This is kind of an old topic I know, but I just ran into the same problem. I'm also on a Powerbook (1.67 G4) so is this just an issue with Powerbooks? Anyway, I'm going to restart in a minute, see if it fixes it.

    Edit: A restart didn't fix it...two restarts did:D
     
  11. ethang macrumors newbie

    Joined:
    Apr 5, 2009
    #11
    system audio volume disabled...

    I have similar symptoms on my 2009 mac mini:
    • Using the digital optical audio out to power external sound system
    • In System Prefs, it recognizes "Digital Out" device
    • The audio plays (!) on my external sound system, but the system volume control is disabled - I get the speaker image with circle/slash like above.
    • restarted a few times and reset PRAM as suggested at http://www.macfixit.com/article.php?story=20090320103158364
    • disconnected optical cable and plugged headphones in and out a few times
    • iTunes volume is adjustable, and also outputs to my audio system, but it doesn't change/affect system volume
    • The audio still works, but the volume control is disabled.
    • ideas?
     
  12. doublebip macrumors newbie

    Joined:
    Apr 6, 2009
    #12
    sound locked

    I have a Powerbook G4 1.67 (10.4.11) and the sound locked up on me too. Haven't changed/added any software in a few weeks.

    Tried most of the suggestions (rebooted several times, reset PRAM, NVRAM). Does anyone have other suggestions I can try before I have to resort to a full reinstall?

    Thanks!
     
  13. ethang macrumors newbie

    Joined:
    Apr 5, 2009
    #13
    Update

    I learned that this always happens when I'm using a digital audio. The mac relinquishes volume control to your digital audio device when it's plugged in using the optical connection.
     
  14. funkytaco macrumors newbie

    Joined:
    Apr 3, 2008
    #14
    I used headphones for the first time today, so I figuired this must've been my problem. This tip worked for me. I haven't used the digital audio out, but I did accidentally put the jack into that one earlier today.
     
  15. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #15
    I had the same problem on a PPC iMac G5 2.1 GHz. I fixed it by deleting two property list files in /Library/Preferences (the global library, not the one in your user folder) then rebooting.
     
  16. nerdsticks10179 macrumors newbie

    Joined:
    Dec 2, 2009
    #16
    Fixed the problem

    I had this problem as well :(. Buuuuuut. I fixed it :eek: !All you do is go to system preferences, and search in the top right search bar "sound output" and the problem is that in the table bit thingy it should be selected "internal speakers" if not select it and it should be fixed! :D
     
  17. hamstertaint macrumors newbie

    Joined:
    Jul 31, 2010
    #17
    Help! I am having the exact same problem. This happened to me about a year ago but it finally resolved itself...I think. Anyway I had a safari update to do when I got on this morning and after the reboot I had no sound. Under preferences it says there is no device found under output or input. Resetting PRAM does nothing.
     
  18. thecraig macrumors newbie

    Joined:
    Jul 18, 2011
    #18
    Solution! (Headphones)

    Plug a set of headphones into your computer. Plug them back out again. This worked for me.
     
  19. vanss2 macrumors newbie

    Joined:
    Apr 26, 2010
    #19
    Solution! (Headphones)

    headphones did the trick for me! i probably put it in the "audio in" in stead of the out port. so plugging it in that port and out again fixed the issue
     

Share This Page