No sound from earpiece or speaker, now its back

Discussion in 'iPhone' started by Dixit, Aug 21, 2007.

  1. Dixit macrumors newbie

    Joined:
    Jun 30, 2007
    #1
    This was wierd. I was on a conference call so I plugged in my headphones so I could work while talking ended the call, unplugged my headphones. Then noticed when I pressed the sleep button I didnt hear the normal "click" when it locks the iPhone. So then I unlock the phone, tried to play something from the iPod portion, no sound, called my house, the ear piece also had no sound, while speaking into the iphone, the house phone heard nothing. If I put it on speaker, then it works, just doesnt work without speaker, plug back in the headphones and they work just fine.

    So then I go to General preferences and Sound and play a few ringtones, that works, but still no sound from the iPod or the earpiece when getting or making a call, have to use headphones or speaker. Turn it off and back on about 4 times, still same problem, basically lost sound.

    So then I plug the headphones in again, again works fine, turn off the phone, unplug the headphones, then turn the iphone back on and what you know, everything works again. Its almost like the iphone got stuck in the mode that it still has the headphones plugged in. And even turning off and on did nothing until i turned it off with the headphones still plugged in.

    Wierd man, wierd.....

    Dixit
     
  2. daemontrader macrumors newbie

    Joined:
    Jul 31, 2007
    #2
    This has happenned to me before after some combination of using headphones, unplugging them and pressing buttons. I assumed it was a software problem that would be fixed at some point.
     
  3. Dixit thread starter macrumors newbie

    Joined:
    Jun 30, 2007
  4. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #4
    FWIW, both my roommates have had this problem and were able to fix it by plugging in the headphones/unplugging them again.

    Def. not just you. :)
     

Share This Page