No sound from imac

Discussion in 'iMac' started by diveo, Oct 30, 2010.

  1. diveo macrumors newbie

    Joined:
    Jan 19, 2010
    #1
    Hi out there, I have a 2007 imac 20", first of the silver ones. I'm running OSX 10.6.4. Suddenly have no sound :confused:. I've had a browse of a couple of threads, but am none the wiser. The speaker icon, top right is greyed out. When I moved the mac, it did provide an intermittent burst of sound, but have not been able to repeat that. Plugging in external speakers does not make a difference. Using the sound up and down controls not helping, just get the normal sound display, but with a stop sign below it (circle with a stroke through it). Is this a return to store job - as out of warranty and out of applecare!:eek:

    cheers
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Go into System Preferences > Sound > Output and take a screenshot and attach it via the [​IMG] button to your next post.
     
  3. diveo thread starter macrumors newbie

    Joined:
    Jan 19, 2010
    #3
    Thanks Spinnerlys,

    I think the screenshot should be attached
     

    Attached Files:

  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    To make smaller screenshots (for future reference):
    [​IMG]

    It seems, you digital output is active, there should be a red light visible inside the headphone/line-out port. Plug a 3.5mm audio connector into that port and pull it out, repeat the process until the red light is gone. It should take less than ten times.
     
  5. diveo thread starter macrumors newbie

    Joined:
    Jan 19, 2010
    #5
    Thanks for that, there was no red light, but it has got the onboard speakers working, but when I plug in my external set, I just get a dull hum from them. Does that make any sense to you?

    cheers
     
  6. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #6
    Can you provide screenshots of when the speakers are connected and when you have them disconnected, using the internal speakers?

    Shift + Command + 4, then leave the keys, press Spacebar and select the window via mouse.
     
  7. diveo thread starter macrumors newbie

    Joined:
    Jan 19, 2010
    #7
    Sorry about that, I've been in and out all afternoon. Just so that I know what I am looking for, what should the screen shots be of? - the same window with and without speakers plugged in?
    cheers
     
  8. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #8
    Yep, one shot with the speakers plugged in and one without.

    And no need to apologise, it is almost always better to be outside than in front of the computer.
     
  9. diveo thread starter macrumors newbie

    Joined:
    Jan 19, 2010
    #9
    Hi thanks again: first is without speakers: the second is with

    Decent day up here in Scotland - blue skies, cold but clear and sunn::Dy! - although sun has just gone down.
     

    Attached Files:

Share This Page