No sound from iTunes when playing mp3's

Discussion in 'Mac Apps and Mac App Store' started by BlckChns, Jul 28, 2008.

  1. BlckChns macrumors newbie

    Joined:
    Jun 6, 2007
    #1
    Freaking iTunes!

    There's no sound when I play my mp3's through iTunes. I can see that it's playing, but no sounds come through the speakers or the headphone jack. The sound works fine when I watch a music video or movie though. I've reinstalled iTunes, but sill no joy. Any suggestions before I do a complete restore?

    Thanks
    D
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Do your MP3 files play in QuickTime Player? If they do, then I suspect you have a corrupt or incompatible iTunes plug-in installed. If not, reinstall QuickTime.
     
  3. HappySnail macrumors regular

    Joined:
    May 26, 2008
    #3
    There are some softwares that can control individual output, make sure this is not on if you have one. Otherwise try a different format, it may be an Mp3 plug in fault.
     
  4. iSee macrumors 68040

    iSee

    Joined:
    Oct 25, 2004
    #4
    Something similar happened to me once and this was the fix:

    http://support.apple.com/kb/HT2178

    Apparently a misbehaving app will set the output rate of the sound card to something high and leave it there. Then, some codecs can handle it and others can't so some sounds play and others don't.

    Anyway, it's worth a shot... Good luck :)
     
  5. BlckChns thread starter macrumors newbie

    Joined:
    Jun 6, 2007
    #5
    Thanks guys. I'll try out your suggestions when I get home.
     
  6. BlckChns thread starter macrumors newbie

    Joined:
    Jun 6, 2007
    #6
    So I figured out where I went wrong. I reinstalled iTunes and that still didn't work. When I double clicked on a song. I noticed that iTunes was connecting to my :apple:TV. I thought that was wierd, so I turned on the TV and there it was. I'm like WTF!!!! My Macbook Pro was like one big giant remote control. It turned out that my iPhone was the culprit. There's an option on the "Remote" app on the iPhone that allows you to turn off your speakers through iTunes. Who knew!
     

Share This Page