No sound from receiver with composite and HDMI

Discussion in 'Apple TV and Home Theater' started by GoCubsGo, Jan 17, 2009.

  1. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #1
    I have a Philips LCD HD TV, a Samsung Blu-ray player, and a HD DVR cable box from Time Warner. All three are connected to a Denon AVR-589 receiver via HDMI. My ATV is connected via composite cable into the receiver. My speakers are the Klipsch B2s, I currently only have two shelf speakers the sub is on the way.

    I've already gone through the speaker setup on both auto and manual (using the optional mic to measure sound and distance) and I've tested both speakers so I know this isn't a polar connection issue.

    I have no sound. I've tried connecting only my Blu-Ray via HDMI ensuring that I have matched the output (PCM in my case), also would cycle through all available sound options with no joy.

    Thinking it was the unit I just returned for another and I still have no sound.

    The obvious replies will be answered:
    The receiver comes with a sort of "trip" in that if the speaker wires are touching something they should not be touching the receiver will shut those speakers off. This is not the case upon successful completion of the test.

    The receiver is on and turned up to at least 30db, this was very loud during speaker testing.

    All components are on and have been set to HDMI out.

    Any advice anyone can give would be great. I almost think it is something so simple that I am missing. The manual has been read and the unit's processing unit had a soft reset performed on it ... twice.
     
  2. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #2
    You get a picture with all of them, just not sound?

    Edit...
    Ah, hang on a sec. My receiver doesn't do sound over HDMI. Maybe yours is the same. You need to connect all the components with optical cables as well.
     
  3. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #3
    Did a bit of digging and it looks like this is correct - your denon only does the picture over HDMI. You'll need to get some more cables...
     
  4. GoCubsGo thread starter macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #4
    I so kicking some teenager's ass!

    Thank you! I have some optical cables to buy. Man you're a lifesaver! Makes me regret hauling the other back to Circuit City. It was a stupid zoo ... for 10% off. :(
     

Share This Page