No Sound HDMI

Discussion in 'MacBook Pro' started by ghsNick, Jun 29, 2011.

  1. ghsNick macrumors 68030


    May 25, 2010
    Ok, I just got this HDMI for my 2011 MBP.

    I hooked it up and notice the computer was on the screen, but under Display (Arrangement) it wasn't Mirrored.

    When I mirrored it the screen (dimensions) didn't look right on my Laptop or TV. So I unchecked Mirrored and set the TV screen (the one to the right) to 1080p on my LCD Laptop screen to 1440X900.

    I kept line Input the same (Internal Mic - Built In) and changed Output to Samsung (my TV) but still no sound through my TV.

    Can anyone help me get sound out of this TV?
  2. DesmoPilot macrumors 65816

    Feb 18, 2008
    Might not be the correct adapter, not all of the MDP>HDMI adapters will do sound out of the HDMI.
  3. Sam2lucky13 macrumors 6502


    May 26, 2011
    preferences/sounds/output/ and select hdmi instead of internal speakers
  4. getz76 macrumors 6502a


    Jun 15, 2009
    Hell, AL
    I have the same adapter and it works flawlessly.

  5. ghsNick thread starter macrumors 68030


    May 25, 2010
    Ok...I got everything to work. A couple questions though.

    When mirroring and watching a computer cuts out and isn't as clear (but the TV is perfect).

    And when I'm not mirroring and have the TV on fullscreen my Computer screen goes black (but I can still see the mouse).

    Is that normal?
  6. NWI73 macrumors 6502a

    Jun 22, 2010
    How come I don't have this option? I believe my mbp is either late 08 or early 09
  7. theLimit macrumors 6502a


    Jan 30, 2007
    up tha holler, acrost tha crick
    It was first in the iMacs in late 2009, and the rest of the Macs got it in mid to late 2010.
  8. NWI73 macrumors 6502a

    Jun 22, 2010
    I have my hdmi to my pioneer receiver so how do i connect an audio cable to my receiver and have sound function when I am on that hdmi input?
  9. elpmas macrumors 68000


    Sep 9, 2009
    Where the fresh snow don't go.
    I would set up the tv as a 2nd's easiest that way imho. also, if you hold down the "option" key and click on the volume button on the menu bar, it'll allow you to choose internal speakers or your tv speakers. it's a faster way than going to sys pref etc.
  10. NWI73 macrumors 6502a

    Jun 22, 2010
    Apparently my MBP doesn't output sound thru the mini display port though. When I go to output, my only option is internal speakers...
  11. Sieben macrumors newbie

    Mar 23, 2011
    Do you have the mini display adaptor connected ? i don't have this option either, but i think it will only appear when the adaptor is connected.

Share This Page