No Sound in Boot Camp?

Discussion in 'MacBook' started by youssefm, Jan 16, 2009.

  1. youssefm macrumors 6502

    Joined:
    Oct 7, 2008
    #1
    Hi, I have a 2.0ghz unibody macbook, and i installed windows xp on the boot camp partition, installed drivers, up until here everything was working fine.. i decided it would be a good idea to upgrade to bootcamp 2.1 and then suddenly the boot camp icon in my system tray went away, and so did the nvidia panel (yet i can find them when i go to sys. prefs.) and the sound no longer worked.. now im stuck and i have no sound. I tried reinstalling the drivers using the cd and it still doesnt work.. also when i remove my headphones there is a red light coming from the jack.. how do i get my sound back???
     
  2. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #2
    can anybody help??
    i've tried googling it and either the instructions are too vague or it doesnt work
     
  3. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #3
    Did you try removing the drivers completely and re-installing them?

    Also, that red light is normal when you remove headphones.
     
  4. eman macrumors 6502a

    Joined:
    Nov 5, 2007
    Location:
    In the great white north
    #4
    The micro switches in the speaker jack are stuck and this is why the red light is on. The macbook speaker jack still thinks you have the headset jack in the port. Try pushing the jack to your headset in and out of the macbook headset port until the red light goes out (hopefully) and then your internal macbook speakers will resume.
     
  5. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #5
    the headphones and speakers work fine in osx.. and how do i remove all the drivers and reinstall them?
     
  6. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #6
    Go to control panel -> Add remove/programs
     
  7. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #7
    oh ok lol, thanks.. i'll try that and get back to you =D
     
  8. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #8
    ok so that didnt work, and it just made matters worst, now i cant access wireless internet, and the cd doesnt seem to install everything.. its acting really weird and im thinking of just removing the partition, and reinstalling windows.. idk yet, i really cant waste the time.. does anybody have any suggestions on what to do now?
     
  9. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #9
    How are you installing the drivers may I ask? I'm asking because I've installed the drivers dozen's of times without any problems, however... on occassion sometimes the wrong window would open to install drivers... therefore it would not successfully install ANYTHING.
     
  10. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #10
    im installing the drivers using the leopard cd that came with my macbook.. i installed them initially with this cd, and it worked until i upgraded to boot camp 2.1, where the sound stopped working, the i followed the advice here and it just screwed it up even more, cuz now my wireless isn't working and i keep getting new hardware found windows and such.. what does it mean when it says "remove bootcamp services" in windows when im inserting the leopard cd (its either repair/upgrade or remove)
     
  11. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #11
    That means it wants to remove the bootcamp services.. lol. Maybe when you removed it from Add/Remove programs it didn't remove everything.

    I would suggest hitting that button and letting the Leopard disc remove everything, then installing everything again and not updating anything. ;)
     
  12. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #12
    thats what i was thinking, but if i do that will it delete my windows partition and windows and all my stuff or just all the drivers?
     
  13. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #13
    Just the driver's. Give it a try and let us know.
     
  14. danvan21 macrumors regular

    Joined:
    Mar 27, 2008
  15. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #15
    That was pretty useless, did you bother to read the thread at all?
     
  16. youssefm thread starter macrumors 6502

    Joined:
    Oct 7, 2008
    #16
    omg thank you!!! removing boot camp services and reinstalling them worked!!! thanks everyone =D
     
  17. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #17
    No problem, glad it worked out!
     

Share This Page