No Sound In Boot Camp

Discussion in 'Mac Basics and Help' started by tycheong, Jan 30, 2009.

  1. tycheong macrumors member

    Joined:
    Jul 31, 2008
    #1
    i recently installed xp pro sp3 onto my unibody macbook pro but theres no sound! yes, i have put in my leopard disk to install boot camp drivers but still no luck. system sounds are not played, the speakers arent even recognized and external speakers dont work also. when i press F10,11,or 12 it shows the muted sound symbol with a crossed out circle on the bottom. keys for screen brightness and backlighting work fine.
    when i go to volume control it says 'there are no active mixer devices available. to install mixer devices, go to control panel..etc.' i tried this and it doesnt work also
    theres a unknown PCI device with a yellow explanation mark next to it and i tried installing drivers for it, says some kind of error. code (or error) 28.
    i also tried installing realtek (or something like that) drivers but those dont seem to work
    i have googled this for solutions but none seem to work
    help plz!
     
  2. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #2
    Which realtek drivers? Should be the high definition audio codecs
    http://www.realtek.com.tw/downloads/
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Did you download Boot Camp 2.1 before installing XP SP3? I don't remember if Apple bundled that on the newer systems of if that update is still relevant but it's worth a shot.
     
  4. tycheong thread starter macrumors member

    Joined:
    Jul 31, 2008
    #4
    i have downloaded the realtek high def audio codecs

    and i have used boot camp 2.1


    its just that i try to raise the volume using the keyboard it always shows as mute
    can somebody give me a detailed 'guide' as to what i can do?
     
  5. flyingnome macrumors newbie

    Joined:
    Dec 27, 2008
    Location:
    Colorado
    #5
    I too had zero sound when on XP.
    I went to apple.com found bootcamp updates while on my XP/ crap side of the Partition. Then downloaded 2.1 ran and installed restarted and voila no problems.
    By the way I had even already installed SP3 for XP and it still worked.
    good luck let us know the results.
     
  6. tycheong thread starter macrumors member

    Joined:
    Jul 31, 2008

Share This Page