No Sound in Leopard - Powerbook G4

Discussion in 'macOS' started by Link2430, Oct 27, 2007.

  1. Link2430 macrumors newbie

    Joined:
    Oct 27, 2007
    #1
    I have no sound while running Leopard...everything is standard in my Powerbook except memory which is 1.5 GB. 17'' Powerbook 1.67 GHz.


    Any help would be greatly appreciated.

    Here are some screens of my problem:
     

    Attached Files:

  2. seamusk macrumors member

    Joined:
    Oct 23, 2007
    #2
    This happened to me on my emac g4. Basically I had to make sure the output was set to the right output and then I had to adjust the volume in the system preferences. I'm not sure what exactly did it, but it worked.
     
  3. Link2430 thread starter macrumors newbie

    Joined:
    Oct 27, 2007
    #3
    That's the problem...it's all grayed out in System Preferences. I can't adjust the volume at all. I don't know what's going on.
     
  4. seamusk macrumors member

    Joined:
    Oct 23, 2007
    #4
    I'm not sure then. Did you try adjusting on the sound effects panel as well? I did that. For some reason, my output device and sound effects devices were set to usb. Yours isn't though.
     
  5. Link2430 thread starter macrumors newbie

    Joined:
    Oct 27, 2007
    #5
    It's grayed out there as well...I can change the alert volume, which does nothing, but I can't change the output volume.

    This is irritating...
     
  6. chambers7 macrumors member

    Joined:
    Apr 30, 2007
    #6
    this is exactly the same problem i am having. first i did archive and install... then i did upgrade.... then i did erase and install... i thought after erase and install it would work, but it doesn't. when i installled, nothing was plugged into the headphone jack. nothing. for some reason though, when i plug in my speakers the volume works again. however, i have no volume on my black macbook (just got it in June).
     
  7. chambers7 macrumors member

    Joined:
    Apr 30, 2007
    #7
    still nothing

    so i stayed on the line calling apple... after an hour and 15 minutes, no result... he suggested i take it to an apple certified technician.
    i reset the vram... (by taking out the battery, holding down power for 10 seconds, putting in the battery, holding down command+option+p+r)and that didn't work.

    my fiance' installed leopard (family pack) same disc, white macbook instead of black... her sound worked fine using archive install.

    i don't have any hacks or special software on my mac. please help!
     
  8. Enterprise8875 macrumors member

    Joined:
    Oct 14, 2005
    #8
    Ok I just had this happen to me on my 12" Powerbook. It was working great with sound since friday and I just plugged in a new external to use with time machine and now no sound. Everything is grayed out and I cant get it back.

    Funny thing is I still get the start up chime.
     
  9. celebi23 macrumors regular

    celebi23

    Joined:
    May 31, 2004
    Location:
    CT
    #9
    Same exact thing happened to me a few weeks ago while still running Tiger. Go into the folder Applications/Utilities & open the "Audio MIDI Setup" app. Make sure the Default & System Output options say "Built-in Output. Next, where it says "Properties for: Built-in Output" make sure the option for "Source" is "Internal Speakers". That's what fixed it for my & I'm sure I had the same problem that you're having now. Hope this helps
     
  10. WOZhipper macrumors newbie

    WOZhipper

    Joined:
    Nov 2, 2007
    Location:
    Mexico
    #10
    If the last response did not help.

    (an I am a certified Apple Tech)

    Check your output jack on the side of the Macbook,IS THERE A RED LED ON INSIDE?

    If that is the case the switch from alanlog to digital is stuck and the Laptop WONT have any sound no matter what you do.

    You have 3 options:

    take it to the genius bar and see if they can reset the switch form the inside.

    Take it to warranty work (new MLB)

    Use a wood tooth wodden stick ( tooth pick I Think they are called) and insert it gently on the output sound jack and press gently downwards until the red light (LED) is off, then you will have sound again.

    BTW some jacks are a little bit bigger or fatter than they should be and they make the switch stuck, avoid usif that plug.

    Regards
     
  11. nnkd macrumors newbie

    Joined:
    Nov 6, 2007
    #11
    same problem

    I have the same problem with one additional symptom. My iTunes will not play songs. It thinks it's playing a song (play button is on play) but the song progress bar does not move.

    I'm using a G4 PowerBook 12". I have Leopard and upgraded to iTunes 7.5 yesterday.
     
  12. nnkd macrumors newbie

    Joined:
    Nov 6, 2007
    #12
    Anyone know a way to fix this?? Let me know, thanks!
     
  13. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #13
    Mine did the same

    same exact thing happened to me this morning on my PowerBook G4 1.5 GHz. I tried to repair permissions, but this had no effect. Next, I re-booted, and this worked - internal speakers magically reappeared. Other people on the Apple board (a good handful of people are having this same problem) have zapped their PRAM and this has worked for them.
     
  14. Enterprise8875 macrumors member

    Joined:
    Oct 14, 2005
    #14
    I called Apple and they told me to put in my leopard disk, boot from cd, run disk utilities, and repair disk. This did fix it for me but it happened again a few days latter and i had to repair disk again.

    I hope 10.5.1 fixes this for good.
     
  15. IzzyJG99 macrumors 6502

    Joined:
    Oct 26, 2007
    #15
    This just started to my iMac G5 2.1Ghz today. It seems just randomly the speakers won't be recognized. Also iTunes seems to be doing all sorts of weird things lately, too. The play/stop button needs to be pushed like 10 times before it actually stops the song.

    Can we say iTunes/Quicktime problems, Kiddies?
     
  16. chambers7 macrumors member

    Joined:
    Apr 30, 2007
    #16
    Solution

    I can confirm a solution that was posted on here earlier. I took my macbook to an apple certified technician (actually two to be exact). One of them told me he had this problem as well. Here is the solution:
    1. Play a song so the red light comes on.
    2. Get a tooth pick and insert it into the headphone jack.
    3. Push gently so the end of the tooth pick is touching the bottom inside the headphone jack.
    4. take the side of the tooth pick and press it against the side of the head phone jack will still keeping the end of the tooth pick pressed on the bottom. Wiggle it around and around. Be patient with it (that's what both myself and the Apple Tech found). The important thing is to make sure the end of the tooth pick is always touching the bottom of the inside of the headphone jack. You will wiggle it around for up to 15 minutes (Usually a lot quicker) until the red light goes off.
    5. Disclaimer: Your speakers will be fixed but there is the possibility that if you plug your head phones into the jack and you pull them out carelessly, you will go back to square one and have to start over.
     
  17. iSaint macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #17
    I hate to ask a simple question, but did you restart your computer?

    I had this problem after 10.5.1 on my 1.67 Powerbook. I freaked a minute, restarted, and all was good! :)
     
  18. gmohr macrumors newbie

    Joined:
    Jan 13, 2008
    #18
    Resetting PRAM worked - I think

    So I lost audio also in my PowerBook G4 1.67, 1.5Gb, not sure why.

    I had no red light in the headphone jack - assuming that's where I was supposed to be looking.

    Tried resetting PRAM by holding down command-option-P-R while starting up. Couldn't tell that PRAM reset, never got a second startup chime (much less a 5th) as instructions indicate. No effect on audio.

    Tried restarting, intending to try resetting PRAM again. Machine would not restart - desktop cleared of all icons but never would shut down. Finally gave up waiting and shut down with power button.

    Restarted again this time holding down ctrl-option-command-P-R (don't know why I held down ctrl and have no idea whether it has any effect at all). Again got no second startup chime, just one. But this time audio is back to normal.
     
  19. bernardt macrumors newbie

    Joined:
    Jan 21, 2008
    Location:
    Pittsburgh, PA
    #19
    I had the same symptom ....as well as memory loss and memory just bleeding. Ran disk Utility and it cleared up but not sure why....Seems like Leopard has a myriad of common issues
     
  20. TimJim macrumors 6502a

    Joined:
    May 15, 2007
    #20
    I have this problem on a Leopard MBP. I tried resetting PRAM, Veryifying Disk and what not, and the tooth pick thing. Nothing has worked so far. As well, i dont see any red LED light that you guys are talking about.

    Anybody wanna help me out?
     
  21. OzExige macrumors 6502

    OzExige

    Joined:
    Mar 9, 2008
    Location:
    Omnipresence
    #21
    Wow, I'm beginning think I'm not alone,
    had the same problem on my iMac after installing Leopard, will try the suggestions tonight.

    Thanks
     
  22. ddalledo macrumors newbie

    Joined:
    Mar 19, 2008
    #22
    Add me to the list. Exact same problem with a PowerBook G4 1,66mhz. It happen sometime, and after some reboots the sounds come back.
     
  23. dhc macrumors regular

    Joined:
    Jan 10, 2006
    Location:
    UK
    #23
    I'm taking my Macbook into to the Apple store tomorrow because of this problem. Not entirely convinced that I'd be happy with an ongoing 'fix' of 'waggling a toothpick'..

    Has anyone had a permanent fix? Has the cause ever really been identified (Hardware -stuck switch/software - Leopard related)?

    It's incredibly annoying..
     
  24. dhc macrumors regular

    Joined:
    Jan 10, 2006
    Location:
    UK
    #24
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    for what its worth, the guys at the apple store are replacing the logic board as the audio socket is attached to it. They seemed to confirm that the issue IS caused by a switch in the socket, and is not software related. On a side note, the new Cambridge store and staff therein were excellent.
     
  25. LizKat macrumors 68030

    LizKat

    Joined:
    Aug 5, 2004
    Location:
    Catskill Mountains
    #25
    Wow, so my situation was not unique! For a minute there today I thought one of my trusty ol' G4 12" PBs, the one running Leopard 10.5.3, was trying to die with its boots on. I lost my audio on it for no apparent reason. I have no idea what triggered it because I was using the machine for awhile before I hit on a track in iTunes 7.6.2 and "nothing happened..." Earlier today I had played a few songs on the thing while loading a nano with a fresh selection of tracks from the library on that machine. The disconnect of the nano was normal and I think I played a few more songs on the powerbook before I put the machine to sleep for awhile. I am not sure it had audio when I woke it up, since the first thing I did after that was just surf the news for a few minutes.

    I never had this happen before, with no audio and iTunes just pretending it was playing but no progress bar was moving. The audio icon had disappeared out of my menubar. My system profile no longer claimed that I had a Texas Instruments something or other in there for audio hardware...

    Well I did a simple restart once, then a safe boot, but couldn't get audio back until I finally rebooted with a PRAM reset, then it came up with its audio working fine. Or at least it's fixed for now. I wasn't using any special software. Running a well maintained Leopard setup and surfing using Firefox 2.0.0.13 and maybe I had a text editor open, Preview, itunes, that's about it.
     

Share This Page