Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

No sound on AppleTV with Airplay

Kyllle

macrumors 6502
Original poster
Apr 25, 2011
290
0
Airplay is working great on my 2012 Macbook Air, except that the volume still plays on the computer itself and does not transfer to the TV when I watch a video. I can get volume working if I listen to music through iTunes, but I want to watch videos on the internet with the sound coming from the TV, not the macbook.

It works fine with videos from my iPad (both audio and video are sent to the TV) but for some reason only the video goes through the TV when I have Airplay on my mac.

Is there some setting I'm missing or is this one of Apple intentional "features" that they put in?
 

mattopotamus

macrumors G5
Jun 12, 2012
13,805
4,303
Airplay is working great on my 2012 Macbook Air, except that the volume still plays on the computer itself and does not transfer to the TV when I watch a video. I can get volume working if I listen to music through iTunes, but I want to watch videos on the internet with the sound coming from the TV, not the macbook.

It works fine with videos from my iPad (both audio and video are sent to the TV) but for some reason only the video goes through the TV when I have Airplay on my mac.

Is there some setting I'm missing or is this one of Apple intentional "features" that they put in?

That is really weird....Audio is suppose to come out of the TV, not the mac. You may have an option checked under the air player preferences in ML
 
Comment

Kyllle

macrumors 6502
Original poster
Apr 25, 2011
290
0
Yeah I checked display and sound preferences, under sound it says that output is Apple TV, and it says the selected device has no output control, is that normal

----------

Ok after restarting the Apple TV it seems to be working. strange...
 
Comment

Hawkeye16

macrumors regular
Sep 16, 2009
208
39
Iowa
I have also had this happen and have tried several things in preferences with no luck. A restart is about all I found as well. It has happened more than once.
 
Comment

ollieo1998

macrumors newbie
Jul 19, 2013
1
0
This problem has occurred for me as well
And then suddenly it played the sound on my tv
 
Comment

SuperDave.GPS

macrumors newbie
Aug 5, 2013
1
0
I just bought a spanking new Apple TV on the weekend (Saturday 03-Aug-2013), hooked it up to my 60" LG plasma, and tried playing video from my 2012 MacBook Air (the MacBook and the ATV all have the latest Apple software/firmware updates).

I also have the same issue as described above.
If I play a personal video (not from the web) from the MacBook, the video comes through the TV wonderfully, but no audio. Audio remains from the MacBook. I've rebooted the ATV several times with no luck.
Audio and video DO work fine, however, when I play the same video from my iPhone5.

One thing that I've noticed is that if I play a video (I'm trying to watch "Dexter" TV show) from any video player other than QuickTime, the audio does NOT go through to the TV. I'm playing the .mkv video with the VLC player, and only the video goes to my TV, while the audio remains coming from the MacBook.
However, if I convert the video to any format that QuickTime recognizes and play the video through QuickTime, all of a sudden the audio goes through to the TV just fine.

Interesting..
 
Comment

garagethrash

macrumors member
Jul 1, 2010
35
6
Started happening to me lately too, possibly because of Mavericks. You can option click the volume icon in the menubar to get sound outputs, including airplay audio. if you select airplay here though the video stops being pushed and it's only audio. But then when you select airplay mirroring again it seems to beam audio+video properly. At least this happens for me.
 
Comment

dagaz

macrumors newbie
Jul 31, 2006
18
1
I've just found a solution online that works for me, type the following into terminal then enter your password:

Code:
sudo killall coreaudiod
 
  • Like
Reactions: CrickettGrrrl
Comment

rcall

macrumors newbie
Dec 25, 2017
1
0
I've just found a solution online that works for me, type the following into terminal then enter your password:

Code:
sudo killall coreaudiod

Thanks very much. This is the only thing that worked for me.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.