No sound / proximity sensor doesn't work on incoming calls

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SheepNutz, Dec 23, 2009.

  1. SheepNutz macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #1
    This past week, my iPhone has been having some problems with incoming calls. When someone calls me, I slide to unlock to answer, and I notice that when I put my phone to my ear, the proximity sensor doesn't turn the screen off, and I can't hear the person on the other end, and they can't hear me. So far this has only happened when I'm on EDGE network, not 3G. Also, if the person tries to call again, the problem will happen a second time, but if they call back a third time, the proximity sensor works and I can now hear them (and vice versa). My phone is on the latest firmware and is jailbroken, but I haven't really changed anything in the past month or two, and the problem has only been happening for a week. I've also tried turning the phone and back off and doing a hard reset, and neither have helped. Any ideas?
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Do you have a case that might be blocking the sensors?
     
  3. SheepNutz thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Kantuckee
    #3
    I'm using an incase slider, and it doesn't come close to the proximity sensors at all. Anyone have any ideas?
     

Share This Page