No Sound - Red Light

Discussion in 'MacBook Pro' started by djasmooth, Sep 9, 2009.

  1. djasmooth macrumors member

    Joined:
    May 24, 2009
    #1
    No clue, what happened, but i plugged in some headphones, and they wouldn't go in.. took it out and saw that some red light was on. Did a SMC and reset the PRAM.. Can someone help? Thanks
     
  2. MacModMachine macrumors 68020

    MacModMachine

    Joined:
    Apr 3, 2009
    Location:
    Canada
    #2
    sounds like your optical light is on, you will need a tooth pick to put in there to flick the switch inside to turn it off, or a toslink adapter.
     
  3. Thiol macrumors 6502a

    Thiol

    Joined:
    Jan 26, 2008
    #3
    Don't worry. It's a well known problem:

    http://forums.macrumors.com/showthread.php?t=239287

    I used a paperclip instead of a toothpick...
     
  4. djasmooth thread starter macrumors member

    Joined:
    May 24, 2009
  5. evil_santa macrumors 6502a

    evil_santa

    Joined:
    Sep 23, 2003
    Location:
    London, England
    #5
    i had 1 set of headphones who's jack caused this to happen all the time, if it happens a lot get some other headphones!
     
  6. djasmooth thread starter macrumors member

    Joined:
    May 24, 2009
    #6
    Yeah that didn't work! I shouldn't have bought those headphones yesterday! If I take it to the AppleStore would they be able to do it?
     
  7. djasmooth thread starter macrumors member

    Joined:
    May 24, 2009
  8. mikes70mustang macrumors 68000

    mikes70mustang

    Joined:
    Nov 14, 2008
    Location:
    US
    #8
    Have you gone to system preferences, and made sure the sound is on bulilt in speakers? If it is on built in speakers, use the tooth pick, if it didnt work you probably didnt do it right.
     

Share This Page