No sound to headset

Discussion in 'iOS 10' started by Braveheart88, May 24, 2017.

  1. Braveheart88 macrumors newbie

    Joined:
    Sep 9, 2016
    #1
    Hello everybody,

    So, apple decided to ditch the headphone jack and that was fine for me. I am using iphone 6s and whenever I upgrade I won't miss the jack. That was my initial reaction.

    Then this problem appeared and it is so annoying when you can't use your phone's basic functions.

    The problem in short:
    - When I get a call sometimes the sound doesn't go to the headset.
    - I have to double tab the speaker icon to receive the sound.
    - Sometimes I have to wait around 10s to hear the other person.
    - When I connect the charger and the headset, I get no sound from the phone or from the headset as if the aound was routed to the lightning port. I have to disconnect it everything and then connect the audio jack.
    - The worst of all when I can't hear anything from the music app, then the sound would disappear totally until I restart my phone.

    These problems occur randomly and some told me to remove skype, wechat and tango and guess what? I did!!

    I am so upset and would sacrifice loosing all the benefits of using apple ecosystem if this problem presist in the next software upgrade.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Could be some sort of a hardware issue with your headphones and/or device. Have you tried cleaning out the headphone jack (and lightning port for that matter)? Have you tried restarting or resetting settings if not perhaps restoring?
     
  3. Braveheart88 thread starter macrumors newbie

    Joined:
    Sep 9, 2016
    #3
    It is definitely not a hardware issue. I heared some of my friends also complaining about the same issue. I tried retoring and this is my second iphone as the first one was replaced by apple because if battery issues.

    Not a hardware issue, because when you tab on the speaker twice you start to get the sound on the headset.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    Have you checked (or tried changing) audio settings under Settings > General > Accessibility > Call Audio Routing?

    Do you have bluetooth enabled?
     
  5. Braveheart88 thread starter macrumors newbie

    Joined:
    Sep 9, 2016
    #5
    I don't have a Bluetooth and the audio routingis set to "automatic"!!
     
  6. panar macrumors member

    Joined:
    Aug 17, 2013
    #6
    This is a bug that drives me absolutely insane! I'm experiencing this nearly every day with the EarPods and the only solution is to restart the phone or to put the call on the speaker. Extremely annoying and unbelievable especially if you are waiting a business call and you have to say to the other person to call you again 3 minutes later to restart your 900€ iPhone in order to work correctly. On top of that, this bug exist since iOS 10, for about a year.
     
  7. Braveheart88 thread starter macrumors newbie

    Joined:
    Sep 9, 2016
    #7
    This is why I am not going to wait for ios 11. I am waiting for the next upgrade 10.3.3 and if the problem is not solved, then I will have to move on. I know how difficult it is since I am stuck with apple since 3gs iphone, but I can't let it f&$@ me every day.

    This also will bring more pain as I will not be able to use the watch.. common apple!!
     
  8. Braveheart88 thread starter macrumors newbie

    Joined:
    Sep 9, 2016

Share This Page