No Sound via toslink cable

Discussion in 'MacBook' started by atad1234, Jul 8, 2010.

  1. atad1234 macrumors newbie

    Joined:
    Jun 30, 2008
    #1
    Hi.
    I have my macbook 2.16 connected to my Marantz AVR via a toslink to mini toslink cable. recently It began to make occasional "bumps" in signal. then It stopped completly. I changed my cable under warrenty but It wasn't the cable. Still no sound! tried everything like connecting cable to both of the AVR digital inputs, reseting Avr, Reseting mac PRRAM, reinstalling snow leopard back to 10.6, q-tip in the mini jack, changing freq source in midi setup from 16 - 20 -24...
    Macbook recognize digital output, red light is strong and bright on the avr side of the cable, all seems good but no audio...AVR says "no data" and the tiny PCM logo dosen't show anymore since problem accurred...
    PLEASEEEEE any new Ideas? I am quite sure the problem is in the mac and not in the AVR... confused:
     
  2. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #2
    It sounds like you've tried almost everything. If you have a movie on your laptop encoded with DTS audio (or a DVD), try playing it with VLC. It has some audio output options beyond what Apple has. This will do nothing more than to troubleshoot Mac OS X's handling of the audio stream. If VLC works, then the problem is in Mac OS X's settings. If VLC doesn't work, try another receiver. Marantz is a great brand, but not infallible.

    http://www.videolan.org/

    -Aaron-
     
  3. finnschi macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Hamburg, Germany
    #3
    maybe try it with windows to check for software issues

    if that does not solve it try another source with the Receiver (DvD player i.e)
     

Share This Page