No Sound

Discussion in 'Mac Basics and Help' started by cycocelica, Dec 29, 2007.

  1. cycocelica macrumors 68000

    cycocelica

    Joined:
    Apr 28, 2005
    Location:
    Redmond, WA
    #1
    So I haven't used my PB in a week (vacation). Got home and turned it on and realized I didn't have sound. The volume control in the menu bar is gone (see picture) and nothing in the Sound Pref Pane works. iTunes also will not play music (click play and it just stays at 00:00). I had nothing plugged in prior to turning it on and nothing is plugged in at the moment. I have also restarted. Any help
     

    Attached Files:

  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    If it's a powerbook rather than a MacBook try the following:

    1: Reboot holding down CMD-OPT-P-R. Keep holding that down until you either hear the startup bong for the third time, or you think your machine has restarted 3 times. Let the machine boot into OS X and see if your sound works.

    2. If the above doesn't work, reboot holding down CMD-OPT-O-F. When it gets to the open firmware prompt, type the following - one on each line followed by 'enter'

    set-defaults
    reset-nvram
    reset-all

    If neither of the above work, and you do not hear a startup 'bong' then you might need to reset the PMU. The method depends on the PB you have, so have a search on Apple's support site for 'reset PMU' and your particular machine.
     
  3. cycocelica thread starter macrumors 68000

    cycocelica

    Joined:
    Apr 28, 2005
    Location:
    Redmond, WA
    #3
    This worked. Thanks for the help!
     

Share This Page