No sounds from digital out

Discussion in 'MacBook' started by marijnvtg, Feb 25, 2011.

  1. marijnvtg macrumors newbie

    Joined:
    Feb 25, 2011
    #1
    Hello,

    Bought a mini-jack to toslink adapter today. Hooked up my macbook (white one from 2008) to my pioneer audio system, but i don't get any volume out of it :( . I've searched the internet so far, but can't find a resolution to my problem. Maybe some of you know a solution?

    To clear some things out;
    - when plugging in the adapter in my macbook, a red light comes out
    - when i plug the toslink cable in the adapter, i get a red light at the end of the toslink optical cable, there where it is connected to my audio system
    - my macbook volume icon turns grey, and checking my sound, it says digital out settings.

    Having a video run thru VLC and audio on iTunes, but no sounds out of my speakers :(

    When connecting the toslink to my samsung tv, i get digital audio thru my speakers right away..

    thank you in advance,

    greetings,

    Marijn
     
  2. jrko macrumors regular

    Joined:
    Feb 4, 2008
    Location:
    Beside the seaside, beside the sea
    #2
    whats your pioneer amp name. I'll see if i can help
     
  3. marijnvtg thread starter macrumors newbie

    Joined:
    Feb 25, 2011
    #3
    the amp/subwoofer is a pioneer sx-sw404

    could it be that my toslink cable is too long (3 meters). i've also connect my macbook to my logitech sound system, also no sound

    thank you
     
  4. jrko macrumors regular

    Joined:
    Feb 4, 2008
    Location:
    Beside the seaside, beside the sea
    #4
    real quick one but have you selected audio in on the remote? It looks like the 3rd button from the right on the first full row of 4 buttons
     
  5. marijnvtg thread starter macrumors newbie

    Joined:
    Feb 25, 2011
    #5
    yes i have. also set it to digital, which works fine when i use toslink cable to ps3 or tv. but to my macbook just wont work. thank you for the suggestion.
     
  6. jrko macrumors regular

    Joined:
    Feb 4, 2008
    Location:
    Beside the seaside, beside the sea
    #6
    other than that is it just 1 optical input or and one toslink or 2optical?
     
  7. marijnvtg thread starter macrumors newbie

    Joined:
    Feb 25, 2011
    #7
    2 optical, tried both of them.

    got a new 1 meter toslink cable today. but no difference.
     
  8. marijnvtg, Mar 1, 2011
    Last edited: Mar 1, 2011

    marijnvtg thread starter macrumors newbie

    Joined:
    Feb 25, 2011
    #8
    ok, now im confused. Plugged my macbook with new toslink to my logitech speakers, it worked. Then plugged my macbook with my new toslink again to pioneer and it worked. So i thought it where some macbook settings and tried my old toslink. No sound. Then plugged my new toslink in, and it als doesnt work anymore.

    Is there some kind of magic steps. Like first plug everything in, then open macbook.
    I dont get it anymore.
     

Share This Page